Well, I thought this would be a fairly simple, two-beer process: set up wordpress, install civicrm, and call it a day. Now I'm stuck and out of beer. I got wordpress installed fine (via the web host's one-click install process), but after activating civicrm and doing the "check requirements and install," when I am taken to the dashboard for the first time, I am met with these errors:

System Status: Error
Cron Not Running
Timestamp Mismatch
Configure Default Mailbox
Complete Setup
View details and manage alerts


I'm on the following:

  • civicrm verson 4.7.2
  • php 5.6
  • MariaDB Server 5.5.44-MariaDB-cll-lve
  • wordpress 4.4.2

This should be a pretty standard install - I quite literally installed wordpress and then civicrm. I've seen the cron and mailbox errors before, but the timestamp and "complete setup" are new to me. I figure if I can push through those somehow, I'll be in business.

This is a fresh install of both the domain and hosting, so civicrm has not worked previously here. I've gotten civicrm running on a personal vm to learn the install process, but this one's throwing me for a loop. If I click on "View details and manage alerts," I am simply taken back to this same screen. No top civicrm menu appears, either, so I can't click around to various parts/modules within civicrm. Clicking on configure or refresh dashboard does takes me back to this screen, as well. I cannot for the life of me get past this screen. The server is hosted in Amsterdam. I have updated the PHP timezone settings to Europe/Amsterdam and Wordpress to +1:00.

I'm not sure where to start with this one - what log files to dig into, etc. I can successfully access other pages I know exist, such as www..com/wp-admin/admin.php?page=CiviCRM&q=civicrm%2Fcontact, where I can search for contacts (though my db doesn't contain any user content yet). I have the same db user configured for the wordpress db and the separate civicrm db (not sure if this follows best practices, but I'm just trying to get past this install screen first). I've given the db user all the necessary permissions and am not receiving any errors indicating db connection issues. I originally had a separate db user for civicrm and wordpress, but in troubleshooting have since blown everything away and started fresh (removed the databases, db users, wordpress install - everything).

Apologies if this is a dumb issue, but I've searched for answers and have so far been unsuccessful. Where do I start with this one? Thank you for any help.

  • Well, I blew everything away again and ran through the manual wordpress install (ignored the one-click web host process) and have encountered the exact same issue.
    – B L
    Commented Feb 29, 2016 at 23:29
  • Despite the scary "Error" message, those are not installation errors, more like "Further things to do".
    – Aidan
    Commented Mar 1, 2016 at 9:14
  • Thanks for the heads up - I've just gotten this working from the solution posted at civicrm.stackexchange.com/questions/9776/…. Those setup errors are still there, but I can click around now and will work towards addressing those - they do indeed appear to be completely unrelated to my actual issue (yay....now where's that beer?).
    – B L
    Commented Mar 1, 2016 at 11:14

2 Answers 2


I followed the instructions on Word Press Install Missing civicrm.settings.php; dashboard unavailable; no menus and was able to add the following immediately after the initial <?php line of my wp-content/uploads/civicrm/civicrm.settings.php file:

global $civicrm_setting;
$civicrm_setting['Directory Preferences']['customTemplateDir'] = 'public_html/wp-content/plugins/civicrm/civicrm/templates/';
$civicrm_setting['Directory Preferences']['customPHPPathDir'] = 'public_html/wp-content/plugins/civicrm/civicrm/php/';
$civicrm_setting['Directory Preferences']['extensionsDir'] = 'public_html/wp-content/plugins/civicrm/civicrm/extensions/';
$civicrm_setting['URL Preferences']['extensionsURL'] = 'https://www.<website>.com/wp-content/plugins/civicrm/civicrm/extensions/';
$civicrm_setting['URL Preferences']['imageUploadURL'] = 'https://www.<website>.com/wp-content/uploads/civicrm/persist/contribute/';
$civicrm_setting['URL Preferences']['userFrameworkResourceURL'] = 'https://www.<website>.com/wp-content/plugins/civicrm/civicrm/';

After quite some time struggling with a wordpress install in a subdirectory, i found the simple setting solved everything: define('CIVICRM_CMSDIR', '/path/to/install/root/');

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.