2

Following instructions on this page, I've set the the CiviCRM wysiwyg to use the Default Drupal Editor, using the Wysiwyg input format. In my Drupal configuration, the Wysiwyg input format is set to use CKEditor. This seems to work in general, but it doesn't work on the CiviMail "New Mailing" page. Just on that page, the editor does change to the CKEditor version set up in Drupal, but none of the settings I've set for the editor in Drupal (under Wysiwyg profiles) seem to apply. All buttons show up in the editor regardless of the ones I select in the settings. This is the case only on the "New Mailing" page. The Wysiwyg shows up correctly on other CiviCRM pages.

Anyone know why this is happening, and whether there's a way to get the wysiwyg profile settings to apply to the editor on this page?

Note: I know Civi 4.7 is coming out with updated wysiwyg functionality, but I'm interested in whether I can get this working in the current version, since I'm not sure when I can update.

Updated to include latest information

4
  • 1
    Are permissions/roles set for using that profile? Mar 2, 2016 at 3:05
  • I have the same issue and I'm logging in with user ID 1
    – Yossi
    Mar 2, 2016 at 18:58
  • Yeah, permissions seem to be set correctly, and the problem happens for user 1 as well.
    – goron
    Mar 2, 2016 at 19:02
  • Turns out this is actually only a problem on one page - the CiviMail "New Mailing" page. Updated the question to reflect this.
    – goron
    Mar 2, 2016 at 19:52

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.