0

in civicrm.settings.php I have if (!defined('CIVICRM_SITE_KEY')) { define( 'CIVICRM_SITE_KEY', '2e554f49c9fc5c47548da5C24da64681b77dca08');

When I use the following URL to start manually all cron jobs, I see that jobs get executed, so the URL seems ok to me. http://xxxxxx.yyy/sites/all/modules/civicrm/bin/cron.php?name=civimail&pass=xxxxxxxx&key=2e554f49c9fc5c47548da5C24da64681b77dca08

The script to start all cron jobs is defined as follows:

!/bin/sh

GET 'http://xxxxx.yyy/sites/all/modules/civicrm/bin/cron.php?name=civimail&pass=xxxxxxxx&key=2e554f49c9fc5c47548da5C24da64681b77dca08'

However, when this script is run, I got this message through mail:

ERROR: Invalid key value sent.

So to me the key seems correct, but even after changing the key to something else both in civicrm.settings.php and in the script, I continue to get this error message. I'm using the latest 4.7.2 civicrm version on drupal 7. For now I'm using easycron, but I'd like to find out if there is an error in this configuration, or if it's a bug.

Any suggestions for further testing ?

thanks Wim

3
2

problem found... it was a confusion between 2 scripts

/home/sitename/www/www/private/civicron.sh /home/sitename/private/civicron.sh

After adapting the correct script it seems okay.

1
  • Could you detail your solution? I am having the same issue. – Tiffany Carra May 10 '17 at 3:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.