1

After activating the CiviCRM plugin within Wordpress and opening the 'CiviCRM Installer' I am unable to alter the CiviCRM Database settings fields to point to my CiviCRM database.

The fields are pre-populated with my Wordpress database details and whenever I alter them and press 'Re-check requirememnts' my details are removed and the Wordpress database details re-appear.

  • Windows Server 2012 R2
  • IIS 8
  • php 5.4.45
  • MySQL 5.1.73
  • Wordpress 4.4.1

The installer for 4.6.x works fine, after upgrading to 4.7.x, the upgrade is successful but I receive Datatables warnings on fields with Tab with table Display styles (such as Relationships) and wanted to try a fresh install.

Has anyone experienced this behaviour before, or able to help me resolve this?

Many thanks
Russell

  • Please provide some screen shots if possible - that will be more helpful – Ramesh - ARTECH Consultancy Mar 3 '16 at 10:51
  • Thanks Christian. While this does seem to complete the install and populate the correct database with tables, the CiviCRM menu bar does not display. I have tried to rebuild the menu using the url: example.com/wp-admin/admin.php?age=CiviCRM&q=civicrm/menu/… but this makes not difference. Am I missing something else here? I had no such problems with 4.6.x – Russell Mar 7 '16 at 11:21
  • Have you tried CiviCRM Admin Utilities? wordpress.org/plugins/civicrm-admin-utilities – Christian Wach Mar 7 '16 at 16:03
  • I meant to add that it will fix the rendering of the CiviCRM menu. There are also options to clear other CiviCRM caches that you can use. Hopefully the combination will bring your menu back. – Christian Wach Mar 7 '16 at 16:04
  • @Russell, the StackExchange format is different than a discussion forum. Your response should be either a comment or (when you have the points required) an edit to your original question. – Joe Murray Mar 8 '16 at 20:34
2

I have seen this behaviour too. Just make sure your database details are correctly entered, then use the "Check Requirements and Install CiviCRM" button above the details instead.

1

There is an issue in the installer for 4.7. I created https://issues.civicrm.org/jira/browse/CRM-19279 to track the issue. With Christian's help I created a PR - https://github.com/civicrm/civicrm-core/pull/9029 I have tested this locally and on one of our test sites and it works.

I'd appreciate any testing that can be done with this to make it a merge candidate.

  • Hi, I am having exactly the same problem I apologise in advance for my naivety here - but how do we access a patch/fix for this? – jkobier Sep 20 '16 at 4:59
  • You can wait until version 4.7.12 or if you know how to apply a patch, this PR github.com/civicrm/civicrm-core/pull/9029/files has the change. -- Basically a few lines were inserted that should have been there from the start - line 121 is where is starts. The patch is "bigger" as there were some code formatting changes done as well. – Kevin Cristiano Sep 20 '16 at 11:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy