3

We have a lot of "Contact Reports" set up and in some of them the contact name links to the contact record but in others it links to another report.

I can't see what it is that influences this. Is it configurable?

  • Are the ones that are linking to others Summary reports aren't they, which they take you through to the Detail report? – petednz - fuzion Mar 3 '16 at 18:59
  • Yes, that seems right. We have some reports on the dashboard that are lists of clients, team members etc and would like them to link to the contact but some do and some don't. I guess the answer is to rewrite the ones that don't as detail rather than summary reports. I'll try that - thanks! – naomi Mar 4 '16 at 9:38
  • I rewrote as an Answer to keep SE happy. you did well to interpret my gibberish – petednz - fuzion Mar 5 '16 at 21:35
0

Sounds like the ones that are linking to others are Summary reports which then take you through to the Detail report. You could try to rewrite the ones that don't click through, and which you want to do so, as Detail rather than Summary reports

  • Thanks. I'm gonna try Jon G's extension first though as it might be easier than rewriting all the reports. – naomi Mar 7 '16 at 14:57
4

This is not configurable out of the box - but I really don't like when clicking on a name in a report doesn't bring you to the contact record. For that reason, I've written an extension called "No Drill Down", which modifies any report that would normally bring you to a Contact Detail or Contribution Detail, and instead brings you to the contact record. You can find it here.

  • Nice one Jon G. – petednz - fuzion Mar 6 '16 at 19:02
  • Hi, thanks, but I'm missing something... I installed the module, it's enabled, but existing reports still link to the summary report. Does the module only work with reports created after it is installed? – naomi Mar 17 '16 at 17:19
  • Actually I just created a new report and it still isn't working for me ... – naomi Mar 17 '16 at 17:23
  • @naomi What version of CiviCRM are you using? – Jon G - Megaphone Tech Mar 17 '16 at 17:59
  • I'm using version 4.7.3 – naomi Mar 18 '16 at 16:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.