3

I am experiencing a strange issue with my CiviCRM (4.7.3) installation on Joomla (3.4.8).

If I change some of the settings in one of the administration pages, they are correctly updated on the database, but if I get back to that page I don't see the setting anymore.

It seems like values for the settings pages are not retrieved correctly from the database.

Any ideas?

  • I've been seeing this as a problem on sites with PHP 5.4 and lower. What is your PHP version – Tommy B Mar 7 '16 at 20:44
  • PHP version 5.6.18 – Stefano Mar 8 '16 at 22:47
  • Two more tests: 1) I have made a fresh new installation of Joomla and CiviCRM on the same server and the issue is still the same. 2) I have made a fresh new installation of Drupal and CiviCRM and the issue is not present. It looks like that the issue is related to CiviCRM on Joomla. Any ideas? – Stefano Mar 10 '16 at 16:35
  • I was having the same problem with our system. On Site Ground, they use Softaculous with the jSGCache plugin enabled. I just disabled it and setting are showing up correctly. It also fixed my problems with creating custom fields other than Text. Finally!!!! Thank you. – Mike Mazurkiewicz Jul 16 '18 at 18:16
2

Could be that the setting is being cached - I've seen this happen on previous versions. Do you have memcached set up? You can normally wait for memcached to refresh, or manually restart it via the command line - 'service memcached restart', on ours.

| improve this answer | |
  • I've tried to disable cache service on Joomla and on the hosting service as well but nothing. The problem only happen with CiviCRM settings. If I check Joomla settings they are showing up correctly. – Stefano Mar 8 '16 at 10:12
2

I reviewed the problem carefully and found that it is caused by the jSGCache plugin that comes preinstalled on all Joomla sites installed via Softaculous. When the plugin is enabled, it adds a special cookie to to prevent caching the admin panel. This seems to conflict with CiviCRM and results in the problem you reported.

| improve this answer | |
1

I wonder if this is a browser cache issue. Also, does Joomla! cache? If so, try clearing that.

| improve this answer | |
  • I've tried to clear the cache on the browser and I've tried different browsers as well. Joomla cache is disabled, I've tried to enable memcache but the issue is still the same. – Stefano Mar 8 '16 at 10:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.