1

When I try to create a new civicrm profile, or to edit the setting of an existing one, there is just a blank space with no buttons or fields. See the attached screenshots.enter image description here I'm using civicrm 4.6.10 and Drupal 7.41

0

I have tested the same against CiviCRM Version 4.6.10 and it works perfectly. So please try to reinstall CiviCRM or try to install an fresh copy of CiviCRM and do the testing - Thanks

0

There are a few things you can try, most of which are detailed here: Troubleshooting JavaScript in CiviCRM. Please update your questions with what you've tried if you still need help!

Also, please edit your question to specify your CMS. Try switching your CMS's theme to Bartik (for Drupal) or twentyfifteen (for Wordpress). Does this change the behavior?

Finally - please check your CiviCRM logs and PHP logs. If you post your CMS version and web server software, someone can help you find them.

UPDATE: Now we're getting somewhere! $.browser is a major clue. CiviCRM doesn't use $.browser (it's deprecated, and removed as of jQuery 1.9). So my guess is another module. Are you running the "jQuery Update" Drupal module? If so, set it to a version < 1.9 and see if it fixes the problem. You might also want to find the module that's calling this outdated jQuery construct and see if you actually need it. You can search your codebase for "$.browser", or just shut off all your non-core extensions and turn half of them on at a time until you've figured out which one causes the error.

  • Just edited my post to include the CMS - Drupal 7.41 and I know it's on apache, not sure which version off the top of my head though. – Matt Muchowski Mar 7 '16 at 22:46
  • Apache 2.2.22 on debian – Matt Muchowski Mar 7 '16 at 23:13
  • Tried Bartik, no luck. – Matt Muchowski Mar 7 '16 at 23:18
  • Also tried looking at any jquery errors that might pop up, saw "Use of getPreventDefault() is deprecated. Use defaultPrevented instead." and "TypeError: $.browser is undefined" – Matt Muchowski Mar 7 '16 at 23:46
  • @MattMuchowski I updated my answer to reflect your new info. – Jon G - Megaphone Tech Mar 8 '16 at 0:11
0

One of my groups' other tech people figured out that it was the file permissions in the CiviCRM template_c and ConfigAndLog directories. Weird.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.