1

Drupal 7 / CiviCRM 4.6.10

We are noticing this issue with this pattern:

  1. A Drupal User has existed for many years with a corresponding CiviCRM record
  2. Has never had a Membership record in CiviCRM
  3. Used a Contribution Page with a Membership Price Set to Become a Member without being logged in to their Drupal account
  4. Our Contribution page has the user account creation required

The pre-existing Drupal account / Civi Record, which they did NOT appear to login to, is receiving the contribution, but NO membership record is created.

I am thinking through all the options here - for a record we reviewed their linked Drupal record says this:

Last seen: 4 years 3 months ago Joined: 11/14/2011 - 7:31am

So - how is this even possible? It seems like maybe they forgot they had an existing Drupal username, created an entirely new one, but then Civi didn't update their record to it, and then the membership is lost?

Thanks for your help.

I've seen this issue: Contribution recorded but no membership created when account creation is used

We are using LoginToboggan (but not a rule) and it is redirecting members to a page after account creation, is it the same issue?

  • can you please give me some more details please - I couldn't recreate the issue - is your contribution page set correctly – Ramesh - ARTECH Consultancy Mar 8 '16 at 11:48
  • Hey Ramesh - as far as I know it is. We have many other people using it every day, able to contribute as completely new members, creating accounts and memberships and contributions. Also, other existing members are able to do this. The accounts that had the issue of no membership created had Relationships to Organizations but I couldn't see any linked membership happening. Is there anything else I could look for, debug? Perhaps the error is limited to the people/records who this happened to based on our data/setup ? – Zachary Mar 8 '16 at 19:27
  • Is this happening only for member who has an relationship with the organization? – Ramesh - ARTECH Consultancy Mar 9 '16 at 9:31
  • Not in our tests. Trying to find more data for you. – Zachary Mar 18 '16 at 22:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.