7

Not sure if this is a valid question for SE, but I thought it as good a place as any to try and assess what Extensions people are successfully using with 4.7.x even where the extension does not state that it is compatible with 4.7

My sense - and very happy to be proven wrong - is that a good many may work, they have just not been tested by the developers, or no-one has updated the release information for them

1

There are two major hurdles preventing my extensions from working:

a) settings storage has changed. Unlike many extensions, mine remove their settings when uninstalled.

b) cj being removed in 4.7 as a valid JS format. My extensions need (in theory) to work on 4.4 and I don't think that allows CRM.$

In short, I'm not convinced that they can be made to work without splitting the codebase along versions somehow.

  • 5
    For JS files using jQuery, I usually wrap all the code with a closure. If do this, you could refer to cj || CRM.$ -- e.g. gist.github.com/totten/9591b10d4bc09c78108d – Tim Otten Mar 12 '16 at 1:58
  • 1
    Phenomenal! I didn't know that was a thing. Do you have an example of how you wrap it in the closure? I know how this is done in jQuery I just want to see it in this context. I.e. if the CRM.$ enclosure contains cj – JohnFF Mar 12 '16 at 2:05
  • 1
    Examples besides the gist? I think a majority of *.js files in civicrm-core provide examples of using a closure, e.g. github.com/civicrm/civicrm-core/blob/4.6/js/crm.searchForm.js . Note how (aside from the last line) one would never refer to cj or CRM.$; instead refer to $. – Tim Otten Mar 14 '16 at 20:57
  • Mine use closures, just not the cj || CRM.$ bit :) – JohnFF Mar 15 '16 at 23:03
  • cj has not been removed in 4.7, FYI. But maybe someday it will be. Tim's suggestion seems like a good safeguard. – Coleman Jun 6 '16 at 18:16
1

bgm says here that the Region Lookup extension works for 4.6, and would require a small fix to work with 4.7.

1

CiviRules is reported as working as far as it's been tested. See: CiviRules and CiviCRM 4.7

1

Thought I would put up something I can maintain as a useful list

CiviRules (G H: SE post)

Email API

Region Lookup - discussed here

0

Email API is working happily on 4.7 along with CiviRules

0

I've been using Multisite Permissioning in production for a couple of weeks now.

Ditto for Summary Fields - but watch out for CRM-18115, a core bug that might affect you if you use Summary Fields with smart groups.

I've also successfully testing inbound/outbound SMS with Twilio.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.