I am using Wordpress 4.4.2 and recently upgraded to CiviCrm 4.7.3. When I try to search for cases under the "find cases" menu, I keep getting the following error messages:

Warning: Invalid argument supplied for foreach() in /home/hillcrest/www/www/wp-content/plugins/civicrm/civicrm/CRM/Case/XMLProcessor/Process.php on line 186

Warning: Invalid argument supplied for foreach() in /home/hillcrest/www/www/wp-content/plugins/civicrm/civicrm/CRM/Case/XMLProcessor/Process.php on line 186

Warning: Invalid argument supplied for foreach() in /home/hillcrest/www/www/wp-content/plugins/civicrm/civicrm/CRM/Case/XMLProcessor/Process.php on line 186

Warning: Cannot modify header information - headers already sent by (output started at /home/hillcrest/www/www/wp-content/plugins/civicrm/civicrm/CRM/Case/XMLProcessor/Process.php:186) in /home/hillcrest/www/www/wp-content/plugins/civicrm/civicrm/CRM/Utils/System/Base.php on line 895

2 Answers 2


I began to examine the case types more closely. Some had matching Name and Title, others did not. Previously, you could change titles but not the Name as they were created in the program files and had to remain as they were.

In any case, next to the Name display there is a lock. I unlocked the lock and then saved. After doing this for each case type, everything began to work fine again. I do not know why this worked nor if it will be permanent but for now, the program works fine. (btw, I had upgraded to Civicrm 4.7.4 before doing this, but the upgrade did not solve the problems at all)


Woah! It looks like you've found a bug :(

These critters pop up every now and again. The thing to do is to add it as an issue on issues.civicrm.org - stating:

  1. the error.

  2. which versions you're on.

  3. what you search for when it occurs.

  4. how to reproduce the same error.

  5. whether or not you are using any extensions - either custom made or generic.

If you are using CiviCRM in a production environment, there's a case to be made for using the "Long Term Support" version (currently 4.6). This will have fewer new features being added, but is well-established and stable, unless there's a feature that you need on 4.7.

  • JohnFF, were you able to reproduce this? Are you sure that this isn't an ACL permissions issue?
    – G H
    Commented Mar 16, 2016 at 14:56
  • An acl issue causing a code warning? This is likely a null being pushed into a for loop. If perms it should fail nicely.
    – JohnFF
    Commented Mar 16, 2016 at 17:40
  • I agree, but Leslie asked another question that looked like a potentail ACL problem: civicrm.stackexchange.com/questions/10477/…
    – G H
    Commented Mar 16, 2016 at 18:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.