2

We would like to restrict access within the WordPress dashboard to the "subscriber" role settings but also have the ability for that user to access the CiviCRM. The only way we can get the CiviCRM link to show in the left navigation is to set the user's role to admin which we don't want. I found this thread here. How to show CiviCRM menu for non admin role using WordPress? However, we have not blocked any access to the menus so there does not seem to be an answer there for us.

We've adjusted the settings through CiviCRM > administer > Users & Permissions > Permissions (Access Control) > WordPress Access Control. So far, we haven't had any luck.

It looks like in the screenshot here that it is possible. (refer to the image in the WordPress Access Control section. https://book.civicrm.org/user/current/initial-set-up/permissions-and-access-control/ I only see the left navigation links for subscriber plus CiviCRM.

Thanks for any and all suggestions.

  • Works for me. Are you sure you've checked "access CiviCRM" for the relevant roles? The "Wordpress Access Control" page has a truly terrible UI where the rows do not line up depending on whether the role names wrap. If in doubt, use "Inspect Element" (or similar in your browser) to make sure you're checking an input with id="subscriber[access_civicrm]". – Christian Wach May 16 '16 at 8:54
  • I apologize, I should have put a comment here. I did finally get it to work with the right combination of settings. – 406CODE May 19 '16 at 13:03
1

Out of curiosity, is this with one of the default Wordpress themes applied? If not, it may be worth switching themes to a default theme and check the functionality. Additionally, if you have the WooCommerce plugin active, it removes the ability for subscribers to see the side menus by default. (You also can't see the WordPress user's Profile page.)

  • 1
    This is a new WordPress in stall with the 2016 theme enabled. Other than CiviCRM, there are no plugins enabled and only hello dolly and askimet installed but not enabled. I've also tried it with 2015 and 2014 themes installed and saw no change. – 406CODE Mar 21 '16 at 13:47
1

I apologize, I should have put a comment here.

I did finally get it to work with the right combination of settings.

Administer > users and permissions > wordpress access control > CiviCRM: access CiviCRM ON for subscriber and CiviCRM: administer CiviCRM off for subscriber. I then selected which other modules I want the subscriber (in this case the employees entering contacts and cases) will need access to (reports, mail, cases...).

Now when my subscriber (employees) sign in they will see in the admin dashboard in the left navigation only links to dashboard, CiviCRM, and profile.

If we go with this solution that is. We still don't have the search functionality working as one think it should.

Thanks for the help and suggestions.

1

I got our Editor Role CiviCRM Dashboard to work by turning on the CiviCRM: access CiviCRM backend and API and turning off the CiviCRM: administer CiviCRM permissions.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.