2

System Details

Versions CiviCRM: 4.7.4
WordPress: 4.4.2

When I attempt to renew an expired membership via the Renew-Credit Card option I am presented with the following error.

Payment Error Response: Error: Invalid API Key provided: ************W4kG

We know the API keys are valid because we have other functions of CiviCRM that are authorizing succesfully with Authorize.net. Any help would be welcomed with open arms. XD.

  • Did you make any progress with this issue. We seem to have the same problem on our site. – Yossi Jun 30 '16 at 18:58
  • I don't believe we did. We actually ended up redoing our CiviCRM installation because of other problems we ran into. – Jesse Riddle Jul 13 '16 at 18:32
2

Not so much an answer as a possible approach to debugging:

1) find out the URL that this command visits and see if you get the same result. If so it's a bug with authorize.net

2) if that URL works then it's a bug with civi. In this case get it to spit out what the api key is and check that against the vale you've entered, checking they're the same.

The error should lie in one of those two places.

1

We had this issue and we solved it by uninstalling the stripe extension. Somehow it was interfering with Authorize.net processing.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.