0

I installed CiviCRM over Drupal. Everything looked fine but when I want to start the module, I get a white screen and the following error when I back to Drupal. I can't enter CiviCRM.

Warning : include(.../sites/default/files/civicrm/templates_c/fr_FR//%%06/069/0693F89E%%drupal.tpl.php): failed to open stream: No such file or directory dans Smarty::fetch() (ligne 1264 dans .../sites/all/modules/civicrm/packages/Smarty/Smarty.class.php).

Warning : include(): Failed opening '.../sites/default/files/civicrm/templates_c/fr_FR//%%06/069/0693F89E%%drupal.tpl.php' for inclusion (include_path='.:.../sites/all/modules/civicrm:.../sites/all/modules/civicrm/packages:.:.../sites/all/modules/civicrm:.../sites/all/modules/civicrm/packages:.../sites/all/modules/civicrm/vendor/tecnickcom:.../sites/all/modules/civicrm/vendor/phpseclib/phpseclib/phpseclib:.:/usr/share/php') dans Smarty::fetch() (ligne 1264 dans .../sites/all/modules/civicrm/packages/Smarty/Smarty.class.php).

My configuration is conformed with the basic requirements asked on the wiki :
GNU/Linux 3.2.65-1+deb7u2 x86_64
Drupal 7.43
CiviCRM for Drupal 7 4.7
PHP Version 5.4.45-0+deb7u2
MySQL 5.5.47-0+deb7u1-log
pcre 8.30 enabled

I changed the permissions to 755 for the 'sites/' folder. But the error still there.

I tried before on my local machine (Debian 8 and PHP 5.6). Everything was great. Why it doesn't work on my host ?

1

Two "simple" things jump to mind immediately. Did you do a recursive change on the sites/ folder, chmod -R 755 sites? Secondly, and I'd assume from the error message that you did, but you did install the l10n package, correct?

  • I just tried a recursive permissions change. Nothing more is happening. I installed the l10n package but I already got the error with template_c/en_US/ ... – ben Mar 18 '16 at 15:37
  • Hrm ... and the group, at least if not the owner also, are the web user? – G H Mar 18 '16 at 16:00
  • I use a shared web hosting service and I think I can't change groups and owners. I just can see and change numeric permissions with my ftp client. And I don't have a ssh access. – ben Mar 18 '16 at 17:53
  • You don't want to leave it this way, but what if you were to put everything to 777? – G H Mar 18 '16 at 18:17
  • It doesn't work more... – ben Mar 18 '16 at 18:37
0

I see from the other answer that you changed the permissions - but it doesn't sound like you have the ability to edit the umask. Depending on what user your web server and PHP process runs as, this could be the issue.

Can you confirm that the files you're looking for exist on the server, and if so, who is the owner/group and what are the permissions? After you fix the permissions, can you confirm that it's complaining about the exact same file not found, or a slightly differently named file? If it's a differently-named file, it's probably a umask issue. In that case, contact your shared hosting support, or find a different host if they refuse to help.

  • The file 'Smarty.class.php' exists and have GID: 33 and UID: 2018. The folder 'templates_c/en_US/' exists and have GID: 33 and UID: 33. But, there's no file in templates_c/en_US/ except a basic .htaccess with '<Files "*">Order allow,deny Deny from all</Files>' I tried to upload my local templates_c folder (because my local setup works). Some part of the layout are now displayed, but it's not enough to use the software. – ben Mar 20 '16 at 15:29
  • 1
    @ben - I think uploading your templates_c is compounding the issue. Without knowing what the UID corresponds to, it's hard to respond definitively - your host's support can help here. But UIDs < 1000 are system accounts, and > 1000 are user accounts. Because templates_c was created by Civi and has a UID of 33, I can deduce that your host uses mod_php or some other interpreter that runs as the web server user, not your user. That means files uploaded by yourself won't be owned by the web server user, which is the heart of the problem. – Jon G - Megaphone Tech Mar 20 '16 at 16:35
  • I think your next step is either to SSH in, or ask your web host provider to resolve the permissions issue for you. – Jon G - Megaphone Tech Mar 20 '16 at 16:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.