5

I received a notice from authorize.net telling of changes to the interface. I did not see any comments so I thought I would ask the question. Does the connections to civicrm require any updates because of:

  • Akamai SureRoute
  • Transaction and Batch ID
  • RC4 Cipher Disablement
  • Thanks for asking... I have the exact same questions... I'm hoping these changes won't break anything? – Gary Zimmerman Mar 24 '16 at 13:31
3

This isn't a full answer, but ... I just had to research this same thing for a client.

  1. Check that your processor config is using the correct URLs: http://www.authorize.net/support/akamaifaqs/#newurls

/civicrm/admin/paymentProcessor?reset=1

  1. Even in our client's old version of CiviCRM, the transaction ID field is 255 characters.

  2. The cipher suite is a question for your host. A good host should be using modern cipher suites and disallowing insecure ones.

  3. Not sure about requiring sequential transaction ID ... have not done a CiviCRM code audit to make sure (yet). Don't see why it would, but who knows.

  • 1
    You can use ssllabs.com to check the cipher suites. – G H Apr 22 '16 at 17:04
2

See CRM-16928, a pull request on CiviCRM 4.6 to update core/xml/templates/civicrm_data.tpl. It is marked as fixed/completed as of 4.7.

  • Thanks for the post. It would be helpful for others if you could provide a direct link to this. – William Mortada May 26 '16 at 17:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.