1

Recently I moved my Wordpress Install with CiviCRM over to a new server. I changed the path location in civicrm.settings.php file to reflect the new location. The front end of appears as if nothing is wrong but on the admin dashboard this appears:

Warning: require_once(/CRM/Core/ClassLoader.php): failed to open stream: No such file or directory in /home/xxx_xxx/public_html/wp-content/plugins/civicrm/civicrm.settings.php on line 399

Fatal error: require_once(): Failed opening required '/CRM/Core/ClassLoader.php' (include_path='.:/home/xxx_xxx/public_html/wp-content/plugins/civicrm/civicrm/:/home/xxx_xxx/public_html/wp-content/plugins/civicrm/civicrm//packages:.:/usr/lib/php:/usr/local/lib/php') in /home/xxx_xxx/public_html/wp-content/plugins/civicrm/civicrm.settings.php on line 399

If I deactivate CiviCRM, everything else appears to work fine, but I need this to work for this site. Any and all help is greatly appreciated!

  • What's on line 399? – Christian Wach Mar 22 '16 at 19:37
  • @ChristianWach The code is 'require_once '/CRM/Core/ClassLoader.php';' – C.Cline Mar 22 '16 at 19:53
2

Looks like you've a couple of hangovers! These are usually in the CiviCRM Administer > System Settings > Resource URLs, and Administer > System Settings > Directories pages. Update those, clear cache, and you should be good to go!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.