2

I have just done a new install of WordPress and CiviCRM, it has displayed this warning when looking at the CiviCRM dashboard:

Environment Settings Timestamps reported by MySQL (eg "2016-03-22 14:45") and PHP (eg "2016-03-22 20:45" ) are mismatched.

The link it refers to is this: https://wiki.civicrm.org/confluence/display/CRMDOC/checkMysqlTime

Which I have read but maybe I am missing something.

I ran this command on MySQL "SELECT TIMEDIFF( NOW( ) , UTC_TIMESTAMP );" and it returns -06:00:00

So then in my php.ini I set date.timezone=America/Chicago to match, then as another precaution I went to the WordPress wp-admin dashboard in the settings and set the timezone to UTC-6 and yet the warning is still displaying, does anyone have any ideas?

3

In testing i determined that all of the UTC offset TZ WordPress offers are invalid from a php perspective.

Set the timezone to the proper php TZ (Europe/Zurich for example) and that error will go away.

  • 1
    Yes, if I am understanding you correctly. I had solved this issue and forgot to update this. What I had to do was in WordPress in Settings > General was change the Time Zone from using the Manual Offset option to a location based option. So in my case setting it to Timezone: New York made the error go away. I cannot locate the forum that eventually led me to this fix but it has something to with how WordPress changes the format of the time string and passes it to CiviCRM before changing it back to the standard format. – LJB Jun 21 '16 at 19:14
2

Sorry for the delay but was I was able to solve my issue, I had set the time zone in WordPress > Settings > General and then changed from manual offset option to location based offset option. This is due to WordPress and CiviCRM handling time differently than WordPress when using the manual offset method.

0

Perhaps clearing CiviCRM cache after changing it in the civicrm.settings.php file will fix it :)

  • The precise question was "does anyone have any ideas?" My idea is that clearing the cache might fix it! – JohnFF Mar 22 '16 at 23:30
  • That's fair. At first read, it looked more like a comment, but I see your point. – Allen Hutchison Mar 22 '16 at 23:45
  • maybe tweak to a 'suggestion' rather than a question ;-) – petednz - fuzion Mar 23 '16 at 3:14
  • Sorry for the delay but was I was able to solve my issue, I had set the time zone in WordPress > Settings > General and then changed from manual offset option to location based offset option. This is due to WordPress and CiviCRM handling time differently than WordPress when using the manual offset method. – LJB Aug 26 '16 at 20:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.