I'm using Drupal 7.43, civicrm 4.7.4., drupal webform 7.x-4.5, and webform civicrm integration 7.x-4.13.

I made a form that would allow users to apply for paid membership. There are a few pages of civicrm tied fields (asking for name, address, other relevant questions), and then a page that ties to a civicrm contribution page.

However, when I test out the page there is some weirdness with the contribution page. The form loads settings from the civicrm contribution page, including a button to 'submit contribution'. Below this is the arrow buttons to go forward or backward on the webform.

When I click just on the button to go forward to the preview page, it goes to the preview page, but the contribution is not processed. If instead I click on the 'Submit Contribution' button, it acts as though I clicked the 'previous page' button and still doesn't process the contribution.

Any thoughts on what might be causing this?

I tried out the contribution page without the Drupal form, and it processed the payment. So I think it's related to the Drupal form. enter image description here

2 Answers 2


See Payment form broken on CiviCRM 4.7

  • That's frustrating. Any ideas when it might be fixed or how to use something else? I installed some civicrm Entities and Entity Forms but don't really know what to do with them. Apr 3, 2016 at 2:25

I understand that this has been fixed in updates. Not sure the exact bug or feature request, but it's worked on our site since I made this question.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.