I am running CiviCRM on a standalone network (for testing purposes) and am getting regular errors about not being able to connect to the CiviCRM site. How can I disable these calls in 4.7?


1 Answer 1


There are multiple calls to CiviCRM.org in the site codebase, so it's not clear which are triggering errors on your site. These are some of the things you could do ...

Disable Version Checking

According to a comment in CRM-17637, from 4.7 it's possible to disable the daily Version Check scheduled task. See under the menu entry Administer > System Settings > Scheduled Jobs.

Disable Community Noticeboard messages

You can disable the connections which update the community noticeboard in civicrm.settings.php.

$civicrm_setting['CiviCRM Preferences']['communityMessagesUrl'] = false;

(Wiki page on overriding CiviCRM settings.)

Redirect/disable connections to CiviCRM.org

You could adjust your server configuration to permit connections to CiviCRM.org, OR you could adjust it to redirect those connections to a local address (eg by adding an entry to /etc/hosts which will direct the requests to a local address).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.