2

If I edit an activity (eg the date or the status) in the Activities tab of the Manage Case page, I get the confirmation message "[activity name] saved". But the edit is not saved.

This problem only appeared after upgrading to 4.7.4. There are no JS errors, no errors on CiviCRM log, no php errors.

Running Joomla 3.4.8. I can't test on the demo, because it's still on 4.6.

Edit: just tried the Wordpress demo, and the problem is present there as well.

Any suggestions where to look for the problem? Thanks.

  • We can see this too. – thoni56 Mar 24 '16 at 11:55
  • Oh dear. I was hoping it was just me. – Jern Mar 24 '16 at 13:57
1

Verified now that the issue is a general problem with CiviCase in Drupal, Joomla and Wordpress versions. I have raised a bug report here.

1

I may have found the solution, but I'm not sure.

At line 418 of civicrm/CRM/Case/Form/Activity.php there is this command:
$params = array_merge($params, $oldActivity);
But this seems to be the wrong way round. I changed it to:
$params = array_merge($oldActivity, $params);

This change appears to fix the problem, but I don't really know what I'm doing, so no guarantees.

0

I know you aren't seeing errors in your logs, however, I did see errors when I attempted to change the Case Type. Here's the link: With an upgrade to 4.7.3, Civicase has become inoperable

There's a comment, perhaps buried, about removing Roles from Case Types, and then things worked for me.

  • Thanks. Since the error only occurs in 4.7.4, and even occurs in a virgin version of CiviCase on the Demo sites (ie without adding any roles to the default case type), I assume that the problem is probably not related to the link you mentioned. – Jern Mar 24 '16 at 20:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.