0

So going through CiviCRM, this error keeps popping up:

Cron Not Running

No cron runs have been recorded.

Unfortunately, I have contacted my hosting provider and asked what cron isn't running related to CiviCRM, and they could not help me unless they knew the name of the cron. I tried seeing what it could be but I cannot find any information on this. I never had this error prior to updating to 4.7.4 from 4.6.10. I tried running a cron in the backend, like system update check, to see if it would fix it but it did not. What can I do to solve this issue?

Thank you.

  • I have the exact same problem, did you find a solution? – Bernhard Apr 26 '16 at 12:09
  • Have you set up a cron to trigger the scheduled jobs? See: wiki.civicrm.org/confluence/display/CRMDOC/… – Laryn - CEDC.org Apr 26 '16 at 14:57
  • I have the same issue with this on 4.7.x. But cron jobs like bulk email are working correctly. This should be filed as a bug, or more explanation given by the crew. – P a u l Apr 27 '16 at 19:42
2

A similar-sounding bug report has been filed here:

https://issues.civicrm.org/jira/browse/CRM-18514

There are scattered reports of cron-related issues in 4.7 but people have been not giving detailed enough information to really pin the problem down. Can you say exactly how you have your Civi cron jobs configured to run? From your question it is not clear that you ever had cron set up correctly... the warning message about that is a new feature in 4.7 - it may simply be telling you about a problem that's been there all along.

|improve this answer|||||
  • I am experiencing this problem on 4.7.15. I am not sure what information would be helpful but I would like to help in anyway can. – Christia Jan 13 '17 at 0:10
0

I'm not sure what you are using to run your crons but in the past I had a similar problem to this and it turned out to be a permissions problem in cli.php. Have a look at root/.../wp-content/plugins/civicrm/civicrm/bin/cli.php and ensure that it is executable.

|improve this answer|||||
0

This was reported and detailed here: https://issues.civicrm.org/jira/browse/CRM-18089

Using the php cli method. The credentials that it is looking for is a CMS User (WordPress) with sufficient permissions in CiviCRM to run the jobs.

I just tested on 4.7.8 CiviCRM with WP 4.5.2 with the following syntax

/usr/local/php56/bin/php /home/user/htdocs/civicrm/wp-content/plugins/civicrm/civicrm/bin/cli.php -u cronuser -p somepassword -e Job -a execute

I can confirm this worked with Drupal as well.

Tested with the URL method on both WP and Drupal. CiviCRM 4.7.8

Both worked with the configuration detailed https://wiki.civicrm.org/confluence/display/CRMDOC/Managing+Scheduled+Jobs#ManagingScheduledJobs-URLmethod

The only caveat: Both the user's password and the site key need to have no special characters. Once I cleared that up, crom was able to run with the URL method.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.