Man I haven't been this frustrated with a plugin in a LONG TIME. Everything I need to do I have to run around in a circle. With that being said I have no choice as this is the plugin my client wants to use.

How the heck to I change the button confirm contribution to Confirm Registration. I have tried the word replacements and it doesn't work. I am using wordpress.


  • 5
    The tone of your question is not very constructive. Hyperbole, capital letters, and blaming are not appropriate ways to communicate with people working out of goodwill to give you something for free.
    – Coleman
    May 7 '16 at 17:41

CiviCRM is a large and complex application. Much of its functionality is covered by unit tests to prevent regressions, and there is a rigorous review and testing process for changes made to the stable releases. However neither of these are foolproof and sometimes things break. We rely on the goodwill of community members such as yourself to find bugs and contribute toward fixing them in a timely manner. Once identified, critical bugs are often solved in a matter of days.

I just tested on a couple of systems and this bug is unusual in that it seems to affect Wordpress (and reportedly Joomla) but not Drupal. That's odd since the CiviCRM core application is identical for all 3 CMSs, and that oddity no doubt contributed to this one slipping through the cracks.

An issue has been filed in the bug tracker for this and it's been marked as critical so it will get highest priority from the core team. If community members step in with debugging info or patches that will move things along even faster.


Regarding the option of using Word Replacements, there's been a bug in 4.7.x, and the simple work-around is to navigate to "Administer => Localization => Languages" and re-save the form. (You don't need to change anything; just re-save the settings.)

The Word Replacements in 4.7 are internally tied to the active language. But on a new installation, the active language may (technically) be new/blank/undefined - and there are no Word Replacements for the blank language. Re-saving the form fixes this by affirmatively setting the language.

For more discussion, use CRM-15813 and PR #8712.


It is a bug affecting 4.7 - I have created a bug here. When facing an issue, please try and replicate it on the various demos. When a bug is found, please report it.

As Karen-Ann said, Word replacement works like a charm on 4.6.


What version of civi are you using? Reason being is, I think there is a bug. Civi 4.7.3 word replacement does not work, previous versions it does. I've got the same problem, was just about to make a post but you beat me to it. :) I'm on joomla as platform, it is an overall bug i think.

  • Man this program just isnt worth it I think. Bugs all over the place. I am using the latest version of it.
    – Gary Wells
    Apr 7 '16 at 3:43
  • If you're running into trouble with features you need, the Long Term Stable version may be a better bet for you. Civi 4.6 - civicrm.org/download/list Apr 7 '16 at 4:48
  • Well that sucks. I thought that the latest stable version would be good. Does that mean I need to start all over again? Man this is PAINFULL!
    – Gary Wells
    Apr 7 '16 at 6:24
  • 4.75 is the version I am using with zero extra plugins
    – Gary Wells
    Apr 7 '16 at 6:24
  • 1
    4.6 word replacement works like a charm.
    – Karen-Ann
    Apr 8 '16 at 20:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.