2

I've validated that my email settings work using SMTP.

Validated using the Contact / Send Email as well as from the Joomla Global Configuration as well as the joomla K2 article print button.

Its just down to testing a sample newsletter mailing. At the bottom is a single email address to send to. I send to an email address for my site (internal to the hosting service) and it works. I try to any other external email address and it fails.

Error msg: Error in call to Mailing_send_test : mail() returned a failure. If I changed the email setting to SMTP, I get a long error, a 'failure to connect to , Invalid SMTP response code received.

Need Help :-(

  • Thanks for the quick response. 1) SMTP settings should OK, since I am successful each time using the hosting services internal email, for CiviCRM Newsletter. Core Joomla works from the global configuration/server tab, as does sending a Joomla/K2 article email. The only problem is CiviCRM's outbound emails have never worked. Here is the system config: System Information Setting Value PHP Built On Linux serv01.siteground343.com 3.12.18-clouder0 #13 SMP Tue Mar 15 13:23:00 EET 2016 x86_64 Database Version 5.6.28-76.1-log Database Collation utf8_general_ci PHP Version 5.6.19 Web Server Apache WebS – Chris G Apr 7 '16 at 2:43
1

Possibly smtp settings, i.e. authentication? Outside of civi, are you able to send an email to confirm your global configuration/server/mail settings are correct?

Then go to CiviCRM, Administer CiviCRM, Outbound Mail. Ensure your settings match the cms. Then test to an outside email address.

If all goes well, go back to civi and try your email.

If still not working, then check what version of php you have, if 5.6, then smtp settings maybe messing you up because of peer verification.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.