0

New to Civi, but not new to CRMs/Wordpress.

When using many of the themes that Wordpress provides (actually this problem occurs with everyone I have tried so far), the field names for a profile signup form do not show up.

With template

However, if I just use the base theme, they do.

Without template

Any suggestions on how to address this?

1

This looks like a CSS issue.

I would suggest to create a new css file in you custom directory like /wp-content/plugins/files/civicrm/my_css/my_stylesheet.css Navigate to Administer->System Settings->Resource URLs and set your Custom css URL to the css file http://yoursite.com/wp-content/plugins/files/civicrm/my_css/my_stylesheet.css more info on how to set a custom CSS path here.

In your CSS file put this:

.label {
   color: #000 !important;
}

The field names/labels are there but they have a white color.

I guess that if put the same style in your Wordpress theme stylesheet section it will override Civi's stylesheet, but the above would be the correct and recommended way to do it.

  • Thanks, I thought it might be a .css issue. I approached it a touch differently, and it seems to work with all themes now. I am using the theme-my-login plugin, and I added the above .label code in the main .css file. So far so good, and it means I can play with different themes. Not sure if that interferes with ACL settings between WP and Civi though. – Andy Von Busse Apr 7 '16 at 19:45
  • Glad you figured it out, but you don't need an extra plugin for that, if you have a FTP access or access to the server, I highly recommend the Custom CSS path. Another tip if you are using a WordPress theme, I would encourage you to create a child theme, that way you have a grained control over styles and customization. – Andrei Apr 7 '16 at 22:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.