0

I'm making a public members directory using using Civi 4.7.6 on Joomla! 3.5.1. It's ok, but I'm getting multiple (clone) results to my search, as seen on the print screen. Any thought about why would it happen?

The results are the very same, not different contacts - i.e., the view link in the right of the result list links to the very ID

Edit

I tried to reproduce the problem in the Demo instance without success (http://joomla.demo.civicrm.org/index.php?option=com_civicrm&task=civicrm/profile&gid=2&reset=1 > try "adams" in Last Name). But I realized that the last search statement in my instance ( Group Status "Added" ) doesn't appear in the Demo. But why it appears on my install? Search preferences are the same on both.

multiple equal results to a directory search

  • Do all the names appear 5 times? If not is there any correlation between the number of times the name appears and something else in their record, for example, the number of email addresses they have? – JoAnne Apr 9 '16 at 7:39
  • good question. multiple website entries also throw strange outcomes which may also affect profiles for all i know – petednz - fuzion Apr 9 '16 at 8:41
  • @JoAnne, good point, I found the correlation, it is directed related to the number of groups the contact is add to. I.e., in the print, Diego Viegas is added to 5 groups and José Diego is added to 3 groups. Indeed, if I turn of "Limit listings to a specific Group?" the problem goes away. So we know why. Do you think it's a bug? – diegov Apr 9 '16 at 14:07
  • I tried to reproduce the problem in the Demo install and it didn't happen, so doesn't look a product bug. But in the Demo test I saw a difference in the search screen from my instance. At my instance there's a " Group Status "Added" " statement in the last line (see print) that doesn't appear in the demo (joomla.demo.civicrm.org/… > try "adams" in the Last Name) . It makes sense to me that this statement is the one causing the issue. But why is it there? I compared my "Search Preferences" to the Demo, it's the same. – diegov Apr 9 '16 at 15:23
  • While editting the profile, click on Advanced Settings fieldset near bottom and investigate options on your system / profile vs one without problems on demo site. HTH. – Joe Murray Apr 9 '16 at 15:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.