1

I am getting the following error after updating to 4.7.6:

Warning: Missing argument 1 for CRM_Utils_System_Joomla::getDefaultSiteSettings(), called in /home/mysite/public_html/administrator/components/com_civicrm/civicrm/CRM/Utils/System/Joomla.php on line 687 and defined in /home/mysite/public_html/administrator/components/com_civicrm/civicrm/CRM/Utils/System/Joomla.php on line 698 Error displaying the error page: Application Instantiation Error: Failed to start the session because headers have already been sent by "/home/mysite/public_html/administrator/components/com_civicrm/civicrm/CRM/Utils/System/Joomla.php" at line 698.

I did not have this error in 4.7.4, skipped 4.7.5 update. Running Joomla 3.5.1 and Php 5.5

  • Did you clear caches in civicrm/admin/setting/updateConfigBackend?reset=1 ? – Laryn - CEDC.org Apr 12 '16 at 17:48
  • Yes I did. This issue with the Reset paths that has come up before is still a problem, so I had to go through and paste the complete paths/URLs into Directories and Resource URLs for everything to display correctly. I still have to use the manual setting in civicrm.settings.php for the extensions path to correct the WSOD when I update Civicrm. Any idea what creates this error? – Hudson Essex Terraplane Club Apr 12 '16 at 17:53
  • May be a bug. See here: issues.civicrm.org/jira/browse/CRM-18089 – Hershel May 15 '16 at 15:49
1

I discovered I had an issue with Joomla's database. Here is the answer I found: The fix is easy:

  1. Enter your Joomla site's backend
  2. Select from the admin menu: Extensions -> Manage -> Database
  3. Click on the FIX button. You may find that some other updates need to be done to bring the database up to 3.5.
  4. Head to Global Configuration, and turn the site 'off' before this next step to discourage any users for a while.
  5. Then, as mentioned above, head to phpMyAdmin and delete all the entries in the xxxxx_sessions table.
  6. Head to the backend and turn the site back on.

http://forum.joomla.org/viewtopic.php?f=710&t=913838

  • Actually this is still a problem. The fix prescribed did not help. It appear that it did but it was just a delay in the error message arriving. – Hudson Essex Terraplane Club Apr 14 '16 at 2:19
0

just pass the argument to this getDefaultSiteSettings(); of your live site url: something like this $this->getDefaultSiteSettings('http://localhost/CiviCrm/'); at line no: 687

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.