2

Using CiviCRM 4.6.15 (and later 4.6.16) integrated in Joomla 3.5.1 I just found out that it is no longer possible to change ACL settings for CiviCRM. It is possible to change a setting, this change is ajaxified and will be shown immediately, however after saving the change it is rolled back to the setting before the change.

I see this in a site that I upgraded from an earlier Civi version, and also in an install of CiviCRM 4.7.6 in a Joomla 3.5.1 site. The readme text with the ACL settings advised to set the value of 'max_input_vars' (defult 1000) higher. I reset this to 2000 and later to 8000. This does not solve the issue with CiviCRM 4.7.6 (now 4.7.7) in Joomla 3.5.1 however.

This seems to be a longstanding bug, see: https://issues.civicrm.org/jira/browse/CRM-15841.

  • My site is running Joomla 3.5.1 with CiviCRM 4.7.5 and I'm experiencing the same issue even after changing and verifying that max_input_vars is set to 4500. – CSDweb Apr 28 '16 at 18:26
  • Same problem with Joomla 3.5.1 and CiviCRM 4.7.3 – Dzseti May 4 '16 at 23:16
1

After updating Joomla 3.5.1 to the latest version Joomla 3.6.0 this problem seems to have disappeared completely. I checked a civi 4.6.19 and a civi 4.7.9 install and both behave well again. You can now change the AVL settings again. I did hear that the acl-part of Joomla needed and got some TLC so I presume this was the culprit in the previous Joomla version.

I did not need to to set the value of 'max_input_vars' (default 1000) higher for this to work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.