2

I am trying to import a csv file as a test into Civicrm. I first exported the exact same file from Civicrm, and then i tried to import the exact same file. When i click on Continue, i get an error "Input file must be in CSV format". I have this error code:

Array
(
    [name] => Map1.csv
    [type] => 
    [tmp_name] => 
    [error] => 6
    [size] => 0
)

Can someone tell me what to do?

With kind regards, Hilco Regterschot

2

Your name sounds Dutch, what often happens to me is that if you open this file with Excel and save it again, it is saved with ; in stead of ,

Could that be the case?

It also is possible it is saved as an Excel file in stead of .csv

  • That's right, i am Dutch ;-).<br/>I have opened the file and saved it bak top csv. I also tried to copy and paste the data into a new csv file, with , as text separator. I also tried to create another file with the same data, but with text seperator ;. ,<br/>In Civicrm i changed Import Field Separator to ; and tried to import again. Same error.<br/>Both times i saved the file as CSV. Do you have other suggestions i can try? – Hilco Regterschot Apr 13 '16 at 13:34
  • please send me (part of) your .csv file – Catorghans Apr 13 '16 at 14:34
  • It is very possible that you have the wrong encoding. To be able to see that you have to send the CSV file, which is what @Catorghans already offered :-) – ErikH - CiviCooP Apr 13 '16 at 14:53
  • I have send the file to @Catorghans. There was nothing wrong with the file. I have asked my client if Catorghans can get access to the site and server, so he can take a look. – Hilco Regterschot Apr 14 '16 at 8:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.