I am installing CiviCRM in Amazon AWS environment. User civicrm has full rights on civicrm database. I certainly see TRIGGER among all others in my phpMyAdmin console. Out of abundance of caution I even gave global TRIGGER permission. Still, I am getting the error. I had a test installation with DB running on the same server as web server and didn't have any problems. Don't know if CiviCRM doesn't see TRIGGER permission because of different host, or because of RDS limitations, or yet something else.

Web Server is Amazon Linux (similar to Fedora/CentOS); Apache 2.4; MySQL is 5.6.27

UPDATE: I tried "root" account and I get the same error. I don't think (or at least I don't know how) I can spool the SQLs that get generated - so if somebody can point me to a query that tries to create a trigger and fails, that would be awesome!

2 Answers 2


On https://stackoverflow.com/questions/8919907/can-i-create-trigger-in-an-rds-db is described how database triggers can be created on Amazon RDS.

Short summary:

  • Create a new Parameter Group.
  • Set log_bin_trust_function_creators to 1.

Turns out, Amazon RDS by default turns on binary logging that prevents "CREATE TRIGGER" to succeed, and CiviCRM interprets this as insufficient permissions. More here. For now I turned off automatic backups and completed installation successfully.

  • Was it possible to turn on automatic backup after the installation? It is a valuable feature of Amazon RDS. Commented Oct 31, 2016 at 8:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.