1

This is a new install Linux - shared hosting with Godaddy.

Joomla 3.5.1

PHP 5.4.45

CiviCRM 4.7.6

I have uploaded and installed CiviCRM. No errors. When I go to Adiministrator>Components>CiviCRM, I get:

Warning: Missing argument 1 for CRM_Utils_System_Joomla::getDefaultSiteSettings(), called in /home/username/public_html/administrator/components/com_civicrm/civicrm/CRM/Utils/System/Joomla.php on line 687 and defined in /home/username/public_html/administrator/components/com_civicrm/civicrm/CRM/Utils/System/Joomla.php on line 698

I get CiviCRM Home, with Configure Your Dashboard link, and the Loading Icon. Also, System Status Errors:

Cron Not Running
Timestamp Mismatch
Configure Default Mailbox
Complete Setup

I have spent countless hours on this today, installing, uninstalling and installing over and over. Same result, every time. I'm fairly certain it must have something to do with the config file and variables, and I've gone over them time and again. Any ideas??? HELP!

Line 698 in Joomla.php:

public function getDefaultSiteSettings($dir) { $config = CRM_Core_Config::singleton(); $url = preg_replace( '|/administrator|', '', $config->userFrameworkBaseURL ); $siteRoot = preg_replace( '|/media/civicrm/.*$|', '', $config->imageUploadDir ); return array($url, NULL, $siteRoot); }

1

The issue was reported on JIRA here: https://issues.civicrm.org/jira/browse/CRM-18411

The patch can be found here: https://github.com/civicrm/civicrm-core/pull/8164

The patch was merged in, so it is fixed in 4.7.7 onwards.

0

just pass the argument to this getDefaultSiteSettings(); of your live site url: something like this $this->getDefaultSiteSettings('http://localhost/CiviCrm/'); at line no: 687

0

Curtis -- Those are not errors, they are PHP warnings. And while it would be good to clean them up in the code, they do not affect functionality. They are present because the error display level in Joomla is dialed up too high. In your Joomla backend, go to System > Global Configuration, click the Server tab and change your Error Reporting option to "none" (which is what it should be set to on a production site).

The system status errors popup in CiviCRM are informative of various configuration pieces you have not completed. If you click the link you'll see more details about those, and will have the option of disabling the notification if desired. For example, if you're just getting the site up and running now, you may not need/want the cron jobs to be running yet, and so you can disable that warning for a week.

  • This worked, as you're right, the error code stopped output. But, I'm still trying to figure out why the error was there to begin with. I tried passing the argument as suggested by SunnY, but that didn't work. I haven't tried out CiviCRM yet, to make sure everything is working, but if a variable isn't present, I'm sure I'll run into problems. – Curtis Holzschuh Apr 15 '16 at 15:49
  • I meant to add, this solved the issue of the error being displayed, so this answer ALMOST solved my problem. But, if I could fix the underlying problem, it WOULD be solved. – Curtis Holzschuh Apr 15 '16 at 16:06
  • First thing I noticed, on CiviCRM Home Dashboard, the link for "Configuration Checklist" goes to mydomain.com/index.php?option=com_civicrm&task=civicrm/admin/configtask&reset=1 and not to mydomain.com/*administrator*/index.php?option=com_civicrm&task=civicrm/admin/configtask&reset=1 – Curtis Holzschuh Apr 15 '16 at 17:36
0

I got the same warning after updating civicrm from 4.6.15 to 4.7.6. I did have the error reporting in Joomla set to Maximum. When after updating the files I tried to run the upgrade database script for civicrm it stalled completely. I concluded that the update failed, reset the error reporting from Maximum tot None, and went back to the upgrade script: that now ran and completed the update correctly. Strange: the warning somehow blocked the database update. In Joomla warnings are not coupled to cms actions or scripts. Perhaps this is different with civicrm?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.