1

I recently set up a new CiviCRM and everything's working fine but there's a couple of error messages that I get in the admin menu that I would love to resolve:

When I go to 'Manage Extensions', this is the warning message at the top:

Warning: Invalid argument supplied for foreach() in CRM_Extension_Browser->_discoverRemote() (line 196 of ...../sites/all/modules/civicrm/CRM/Extension/Browser.php).

And it doesn't list any extensions that are available.

I also remember seeing a similar warning about something it couldn't validate but I can't recreate it. I've enabled the Drupal logging so that I can pick it up if it happens again.

EDIT:

Also seen similar question here but no reply: https://stackoverflow.com/questions/35456655/warning-invalid-argument-supplied-for-foreach-in-crm-extension-browser-disc

And issue raised here but no response: https://issues.civicrm.org/jira/browse/CRM-18054

  • Confirming this occurs on a site we may be taking responsibility for, same line number. Drupal/CiviCRM 4.6.17 – Joe Murray Jul 14 '16 at 19:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.