0

Apparently I am not allowed to ask for clarification in the post, so can someone please elaborate on this?

Sounds good. To be sure, please execute ///civicrm/menu/rebuild?reset=1&triggerRebuild=1 which fixes the trigger and function definitions in the database."

It looks like I need to do this, but where/how? I asked my hosting provider and they referred me back here. :/

2

Sorry for the too terse explanation you received on the other answer, using a shortform that experts are used to. If you are running a Drupal site, example.com, then to rebuild your triggers navigate in your browser (by pasting in the url) to http://example.com/civicrm/menu/rebuild?reset=1&triggerRebuild=1 , for WordPress it is http://example.com/wp-admin/admin.php?page=CiviCRM&q=civicrm%2Fmenu%2Frebuild%3Freset%3D1&triggerRebuild=1 , and for Joomla it is https://example.com/administrator/?option=com_civicrm&task=civicrm/menu/rebuild?reset=1&triggerRebuild=1.

Without a reference to your earlier question, I'm not sure which version of CiviCRM you are running. FWIW, I think this fixup may have changed in recent versions.

Make sure you have admin CiviCRM permissions.

  • Thanks, Joe. Actually, it was answer to someone else's question, but it wouldn't let me ask there for clarification. I did try to paste the URL replacing example.com with my domain but it says I do not have permission to execute this URL. :/ It had to do with the MyISAM database engine issue. I changed them all to InnoDB, but still getting the error in the System Report. Should I contact my hosting provider and ask them to run the URL or is there a permission I can change myself? – Rod W Apr 15 '16 at 19:03
  • Hi, Joe. I'm using CiviCRM 4.7.6 on Drupal 7.43. I pasted the URL (replacing with my domain name) and received a successful message, however, the system is still showing the MyISAM error. Any thoughts about how to fix it? – Rod W Apr 23 '16 at 12:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.