Since the last two updates I am having severe issues with the views integration with Drupal. The views module hasn't changed, but it doesn't seem to work after the 4.74 and 4.76 updates.

When upgrading to 4.74 I lost all the custom fields in the integration and now with the 4.76 I lost even more fields like event names, dates and contact fields.

Does anyone else have this issue and knows how to fix it?

2 Answers 2


Have you tried clearing all Drupal caches then running update.php for Drupal? This fixes views for me

  • Thank you... that seems to fix the issue I had with the last update. However I still have the issue with the custom fields. SQLSTATE[42S22]: Column not found: 1054 Unknown column 'civicrm_contact.custom_7' in 'where clause' I still have this issue and the column indeed does not exist.
    – Ronald
    Commented Apr 16, 2016 at 17:11
  • 1
    if you are using civicrm entity module you often get Fields showing in Views - those are the ones that have 'no help' or somesuch message in your Field selector - avoid those ones.
    – petednz - fuzion
    Commented Apr 17, 2016 at 21:11
  • The Entity module seems to indeed be the problem. I disabled the entity module and the fields show up fine now.
    – Ronald
    Commented Apr 19, 2016 at 6:41

In my case I needed civicrm_entity_views_extras and therefore both entity and civicrm_entity, so disabling is not an option. My civicrm views break as soon as I migrate from production to stage. Clearing all drupal cache (which includes views) is not helping me. The only thing that seems to help is

  • Access the failing view
  • Specifically clear the views cache (drush cc views)

Apparently it should fail once and only then after cache cleared again, the cache is finally build properly. I will try now to deactivate views cache before migrating to see if that helps.

  • The best solution imho is to simple disable views data cache in advanced views settings. I did not notice any speed gain in my situation and reports are not accessed by all and not daily.
    – ñull
    Commented Feb 8, 2018 at 13:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.