Wordpress 4.5 CiviCRM 4.7.6

I have installed the CiviCRM 4.7.6 plugin and get a message that I need to upgrade the database. When I try the upgrade, get a white screen displayed with the single word "error" in the upper left. Then I cannot access any Wordpress functions and have to reload the datbase again.

  • If you check the log files (usually in <wordpressroot>/wp-content/plugins/files/civicrm/ConfigAndLog) do you see any more info about the error? Apr 21, 2016 at 4:18
  • There is no such directory, civicrm, in that path
    – Vietyank
    Apr 21, 2016 at 7:11
  • Search your file system for the ConfigAndLog directory, it's there somewhere! Apr 21, 2016 at 15:21
  • Nope...it doesn't exist
    – Vietyank
    Apr 21, 2016 at 15:31

3 Answers 3


Ran into something similar. There are some database table alteration between 4.7.5 and 4.7.6 (specifically relating to foreign keys). These edited CiviMail tables. If you have used CiviMail extensively, these tables could be quite large. The ALTER TABLE commands can take a very long time causing time outs.

The quickest option is to backup these tables, trucate them, run the CiviCRM 4.7.5 to 4.7.6 upgrade comands, and, finally, reimport the data.

Affected tables:

  • civicrm_mailing_event_queue
  • civicrm_mailing_recipients
  • I've never been able to get CiviCRM running on this site so these tables have not been used. I have not sent out any CiviMail
    – Vietyank
    Apr 21, 2016 at 15:32
  • I tried the steps above by setting the foreign_key_checks = 0 then truncated the tables and setting the checks back to 1. This did not help. I still got the error page when I ran the upgrade script
    – Vietyank
    Apr 23, 2016 at 3:56
  • I am going to start all over again. I have deleted the civicrm files and will attempt a fresh install
    – Vietyank
    Apr 23, 2016 at 4:55

Same thing with Joomla but this is a database issue, not website platform. Seems there is an error with a FOREIGN_KEY_CHECK or field during 4.7.5 schema update. See screenshot.

enter image description here


This question is a duplicate of Upgrade Fails 4.7.4 - 4.7.6 in WP 4.5.1. This question was asked first, but it couldn't be diagnosed. The original poster's theme and/or PHP settings are suppressing error output that others like @BruceW had.

I'm going to say that the answer to this question is "use the default theme when troubleshooting upgrade issues" and turn PHP error reporting to maximum. I'll answer the actual issue on the other question, since that one is more likely to be found by others.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.