0

This is a re-install. I was unable to upgrade a previous version but it had not been used so I deleted all the CiviCRM tables.

I then deleted the civicrm directory under plugins and in the wp root so theoretically, there should be no remnants of civicrm.

I then unzip the .zip file into the plugins directory.

After that, I activate CiviCRM in Wordpress. The first clue that something is wrong is that I get an Initialization Error with messages that say that the table civicrm_settings does not exist. Of course, it shouldn't exist because this is a new installation.

I then tried to run http:///wp-admin/options-general.php?page=civicrm-install with my site and got the error You do not have sufficient permissions to access this site.

The CiviCRM plugin is activated, as I said above.

Is there something else I must clean up before I can install it?

  • I found another directory with CiviCRM files in it so I deleted that. I then was able to active CiviCRM without any table not found errors. I then went through the installation process and it completed successfully. Now, when I go to CiviCRM home and click on "View details and manage alerts", I get a white page with the single word "error" in the upper left. I am unable to do anything with CivicRM Seems that I am back at square 1 – Vietyank Apr 23 '16 at 5:46
  • There are no logs that give me any clue about is wrong – Vietyank Apr 23 '16 at 6:07
  • here is what I see on the CiviCRM Home Page System Status: Error Cron Not Running Configure Default Mailbox Complete Setup View details and manage alerts – Vietyank Apr 23 '16 at 6:35
  • Just a long shot, but how did you delete all the civicrm files to do a reinstall? It sounds to me that from the message "civicrm_settings does not exist" there may still be some remnants of the original civicrm installation somewhere. I understand that to delete all files, you should be logged into Wordpress when deleting the plugin from the installed plugins in Wordpress Admin. All the files may not have been deleted if you attempted to do so via FTP. Also, have you re-started with a fresh database outside of the Wordpress database or as part of the Wordpress database? – peterb Apr 26 '16 at 17:35
1

For a clean CiviCRM reinstall under Ubuntu / LAMP / Wordpress to work, the initial clearing of all CiviCRM related files is essential. If there are any vestiges of a prior installation left, the reinstall will certainly fail (either with an Initialization error, or the "You do not have sufficient permissions..." error).

Here are the necessary steps to reinstall (not upgrade) CiviCRM, using the desired / most recent version.

1. Review the directory structure to be sure it is as specified.  OK.
    1. Get to the proper directory:   
       (for my configuration:  var/www/wordpress/wp-content/plugins/).
    2. Remove all civicrm files and folders:  
sudo rm -R ./civicrm
    3. Remove civicrm log and cache files and folders:  
cd ./files
sudo rm -R ./civicrm
    4. Remove the civicrm.settings.php file, if present from prior work.
cd ../civicrm
rm civicrm.settings.php
    5. Check the wp-content/uploads directory for a civicrm subdirectory and files; 
       remove if found:  
cd /var/www/wordpress/wp-content/uploads/
ls -al
(check for civicrm directory and files and remove if they exist)
sudo rm -R ./civicrm
2. Use wget to pull down the desire / most recent zip file.  OK.  

3. Unzip the file.  OK.  

4. Use sudo chown to set file ownership as appropriate.  OK.

5. In your favorite browser, login to Wordpress and check the Wordpress plugins list to see if the CiviCRM plugin shows up (you may have to refresh the window).  OK.

6. It does, click the Activate button.  OK.  

7. Activated.  OK.  

8. Navigate to:  https://yourwebsite.org/wp-admin/options-general.php?page=civicrm-settings  

9. If success, you can now see the installation page.  

10. Click the configure CiviCRM button and get the green bar screen! OK.

You have now reinstalled CiviCRM. From here, follow the CiviCRM how-to for configuration details.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.