0

All of the event registrations on our website are throwing the following error message:

    0 - <div id="crm-container" class="crm-container" lang="en" xml:lang="en"> <style type="text/css" media="screen"> @import url(/administrator/components/com_civicrm/civicrm/css/civicrm.css); @import url(/administrator/components/com_civicrm/civicrm/bower_components/jquery-ui/themes/smoothness/jquery-ui.min.css); </style> <div class="messages status no-popup"> <div class="icon red-icon ui-icon-alert"></div> <span class="status-fatal">Sorry but we are not able to provide this at the moment.</span> <div class="crm-section crm-error-message">id (value: ) is not of the type Positive</div> <p><a href="https://www.usfashionindustry.com/" title="Main Menu">Return to home page.</a></p> </div> </div> <script language="JavaScript"> function toggle( element ) { var className = element.className; if ( className == 'crm-accordion-wrapper collapsed crm-fatal-error-details-block') { element.className = 'crm-accordion-wrapper crm-fatal-error-details-block'; } else { element.className = 'crm-accordion-wrapper collapsed crm-fatal-error-details-block'; } } </script>

You may not be able to visit this page because of:

    an out-of-date bookmark/favourite
    a search engine that has an out-of-date listing for this site
    a mistyped address
    you have no access to this page
    The requested resource was not found.
    An error has occurred while processing your request.

Please try one of the following pages:

    Home Page

If difficulties persist, please contact the System Administrator of this site and report the error below.

<div id="crm-container" class="crm-container" lang="en" xml:lang="en"> <style type="text/css" media="screen"> @import url(/administrator/components/com_civicrm/civicrm/css/civicrm.css); @import url(/administrator/components/com_civicrm/civicrm/bower_components/jquery-ui/themes/smoothness/jquery-ui.min.css); </style> <div class="messages status no-popup"> <div class="icon red-icon ui-icon-alert"></div> <span class="status-fatal">Sorry but we are not able to provide this at the moment.</span> <div class="crm-section crm-error-message">id (value: ) is not of the type Positive</div> <p><a href="https://www.usfashionindustry.com/" title="Main Menu">Return to home page.</a></p> </div> </div> <script language="JavaScript"> function toggle( element ) { var className = element.className; if ( className == 'crm-accordion-wrapper collapsed crm-fatal-error-details-block') { element.className = 'crm-accordion-wrapper crm-fatal-error-details-block'; } else { element.className = 'crm-accordion-wrapper collapsed crm-fatal-error-details-block'; } } </script> 

The website is running Joomla 3.5.1 and CiviCRM 4.6.15. We've made some changes recently to the profiles and did a large site upgrade a few weeks ago, but I'm still trying to track down when the issue started.

To troubleshoot, I've checked the resource URLs and the site config, all are setup to use https://www and the URL doesn't change when moving from one page to the next.

When I attempted to set up the Site Profile settings, that throws an error message as well:

There was an error in reading your site configuration.
Snapshot ID uOV7F-LqpIP-vGUht-frahE
Timestamp   2016-04-26 21:39 UTC
Status  error
Site URL    https://www.usfashionindustry.com/administrator/administrator/components/com_civicrm/civicrm/extern/cxn.php
App URL https://mycivi.org/app:org.civicrm.profile/cxn/register
Data    {"is_error":1,"error_message":"Client exception: Received garbled message","garbled_message":false}

I don't know why "administrator" shows up twice in the URL. With our Joomla install, there are two civicrm.settings.php files, and the one in the administrator directory has /administrator as part of the site URL. I tried changing this to see if that made a difference, but instead it broke some other back-end functionality.

Enabling error messages and debugging also hasn't turned up additional clues. I also tried changing the template on a registration page to see if there was a scripting conflict with the template (which is old), but the error persisted. Any thoughts? I'm tempted to upgrade to 4.7.x to see if that solves the problem.

The following is from the CiviCRM.randomstring file in the ConfigAndLog folder (with the root removed):

Apr 26 22:13:33  [info] $backTrace = #0 /administrator/components/com_civicrm/civicrm/CRM/Core/Error.php(364): CRM_Core_Error::backtrace("backTrace", TRUE)
#1 /administrator/components/com_civicrm/civicrm/CRM/Utils/Type.php(371): CRM_Core_Error::fatal("id (value: ) is not of the type Positive")
#2 /administrator/components/com_civicrm/civicrm/CRM/Utils/Request.php(85): CRM_Utils_Type::validate("", "Positive", TRUE, "id")
#3 /administrator/components/com_civicrm/civicrm/CRM/Event/StateMachine/Registration.php(52): CRM_Utils_Request::retrieve("id", "Positive", Object(CRM_Event_Controller_Registration), TRUE)
#4 /administrator/components/com_civicrm/civicrm/CRM/Event/Controller/Registration.php(47): CRM_Event_StateMachine_Registration->__construct(Object(CRM_Event_Controller_Registration), TRUE)
#5 /administrator/components/com_civicrm/civicrm/CRM/Core/Invoke.php(307): CRM_Event_Controller_Registration->__construct("Event Registration", TRUE, "null", NULL, "false")
#6 /administrator/components/com_civicrm/civicrm/CRM/Core/Invoke.php(86): CRM_Core_Invoke::runItem((Array:15))
#7 /administrator/components/com_civicrm/civicrm/CRM/Core/Invoke.php(54): CRM_Core_Invoke::_invoke((Array:3))
#8 /components/com_civicrm/civicrm.php(86): CRM_Core_Invoke::invoke((Array:3))
#9 /components/com_civicrm/civicrm.php(11): civicrm_invoke()
#10 /libraries/cms/component/helper.php(405): require_once("/components/com_civicrm/civicrm.php")
#11 /libraries/cms/component/helper.php(380): JComponentHelper::executeComponent("/components/com_civicrm/civicrm.php")
#12 /libraries/cms/application/site.php(191): JComponentHelper::renderComponent("com_civicrm")
#13 /libraries/cms/application/site.php(230): JApplicationSite->dispatch()
#14 /libraries/cms/application/cms.php(257): JApplicationSite->doExecute()
#15 /index.php(49): JApplicationCms->execute()
#16 {main}
1

Have you gone and resaved all the menu items? The way the menu item saved in the most recent versions of CiviCRM in Joomla has changed. CiviCRM throws this error in Joomla if you haven't selected one of the necessary settings in the menu item.

I would also check the (root)/media/civicrm/ConfigAndLog/CiviCRM.longRandomString.log. I have found it very useful.

  • Yes, I checked through the menu items and rebuilt each menu. The events themselves show up and are working fine. It's after hitting "Continue" on the registration page that the error pops up. It's a new one for me and all of the troubleshooting so far hasn't provided any clues! – LMK Web Apr 27 '16 at 2:14
  • What is the content of the (root)/media/civicrm/ConfigAndLog/CiviCRM.longRandomString.log file? – David Hayes Apr 27 '16 at 3:17
  • It's similar to the error message, but with the backtrace info as well. I looked at it earlier but wasn't sure how to read it. It's too long for the comment so I've appended it to the original post. code Apr 26 22:13:33 [info] $Fatal Error Details = Array ( [message] => id (value: ) is not of the type Positive [code] => ) – LMK Web Apr 27 '16 at 5:10
  • Ok, so this line is the one throwing the error: CRM_Utils_Request::retrieve("id", "Positive", Object(CRM_Event_Controller_Registration), TRUE) Do you have customize CiviCRM templates? – David Hayes Apr 27 '16 at 15:46
  • Another thought -- CiviCRM is looking for a variable id to be passed in in the $_REQUEST. It is not being passed in. I believe it is the event id and it is provided by the menu item settings. If you check the source of one of the forms , is the Itemid set in the action url? <form action="https://example.com/index.php?option=com_civicrm&amp;task=civicrm/event/register&amp;Itemid=1168" method="post" name="Register" id="Register" class="CRM_Event_Form_Registration_Register" enctype="multipart/form-data" data-warn-changes="true"> – David Hayes Apr 27 '16 at 16:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.