1

I use CiviCRM Webform to manage complex Event registrations.

At the end of registration, an email is sent to the registrant, which contains a submission URL, in the form of : https://www..../?q=node/xx/submission/yy

But this URL is refused except for the Administrator

How must I manage Access Control, so that the registrant can access AND edit this submission ?

3

I think you need to grant the Webform: Edit own content permission. This may still not give access to view the submission (haven't tried) but it would give the user access to edit their submission, which is probably more important (tweak the link you email out to edit rather than view the submission).

If all you want is to allow the user to see their submitted values, I second Karin's suggestion that you put them in the body of the email. This way the user can see them immediately without needing to click on a link.

  • Thank you Coleman, I did not realize this "content access" permission prerequisite – Jacques-Marie Moranne May 31 '16 at 7:45
2

A couple of thoughts:

1) I tend to always delete the submission URL from the webform Email notification. To give authenticated users access to their Webform Submission tuck it into a View where you filter the View /user/%/submissions [a contextual filter (Webform Submission User) User: Uid] so that they can only see their own Submissions - and create a Menu Tab for them in their My Account.

2) As @Kboy mentioned - you may just want to Email them all Values of the webform - if you want to pretty that up - you can make that a HTML Email format: here is a pretty good tutorial: https://www.ostraining.com/blog/drupal/html-emails-from-drupal-webform/

  • 1/ I am not familiar enough with Views, but I keep this in mind ... 2/ I also keep in mind Kboys suggestion ... 3/ However, I really wanted the user to be able to edit (i.e. update) his submission, which is complex. Thank you Karin – Jacques-Marie Moranne May 31 '16 at 7:49
1

permissions per webform can give you more control on who has access to the webform submissions but i wonder if you really want to give results access to anonymous users, this mean that all non authenticated users will see the results tab on the webform.

  • Thank you Kboy for your quick answer : I understand that this is rather a Drupal issue than Civi : I will test your suggestion. But, from my point of view, it makes no sense that a submisionner cannot see his own submission, natively. – Jacques-Marie Moranne Apr 30 '16 at 7:48
  • I have installed (and activated) permission per webform, but it does not show the PERMISSION SETTINGS frame as shown here : drupal.org/files/project-images/permissions_per_webform.png ; did I miss smth ? – Jacques-Marie Moranne Apr 30 '16 at 10:31
  • go to form settings, under permission settings , Enable permissions per webform for that particular webform. I also think you can send the submitted values to the submitter using webform tokens by email instead of allowing the submitter to access the webform results. – Kboy Apr 30 '16 at 11:40
  • Thank you Kboy : I had not seen this "Enable permissions per webform" control – Jacques-Marie Moranne May 31 '16 at 7:53
1

Jacques - rather than giving the edit webform (ie the node) you can give

  • Access own webform submissions
  • Edit own webform submissions
  • Yes, but Content-Access Permission is a prerequisite : this is what I did not realize. – Jacques-Marie Moranne May 31 '16 at 7:48
  • oh really - no i did not expect that. sounds wrong but take your word on it. – petednz - fuzion May 31 '16 at 8:53
  • I am speaking of "Grant own content access" permission ; but you make me doubt now. – Jacques-Marie Moranne Jun 3 '16 at 13:07
0

I finally used Webform: Edit own content permission ... which worked Thank you all

  • 1
    You want them to Edit their own Event Registration? I'll edit you Question - and then you'll want to accept @Coleman's answer - to keep SE happy – KarinG - Semper IT May 30 '16 at 11:39
  • 1
    Remember always feel free to upvote answers that were helpful to you 😀 – KarinG - Semper IT May 30 '16 at 11:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.