2

I recently moved my CiviCRM install from a local in-house server to a cloud server hosted by Siteground. Everything is working beautifully except for the import and export.

My database is around 60,000 names.

When I try to import a list of 5000 names to update their addresses, it gets through about 600 records (exactly 3 minutes) and then reverts back to the initial import page. Sometimes it has failed in 2 minutes, but no longer than 3. I can't find in Drupal logs showing a failure. I contacted Siteground and asked them to increase my max_execution_time, memory_limit, and max_input_time. They showed me how to do it myself and I tried it. Still no change. I disabled geocoding and it got to 3 minutes and 15 seconds.

So I tried exporting 45,000 contacts (a process I run about 4 times a year) and it lasted 3 minutes as well and then reverted back to the Search Builder page (where I started the export).

What setting is causing this issue? Siteground fixes things pretty well so I just need to know what to tell them.

Thanks, Paul

1

I am not a developer, but I believe you are running into timing out issues and you may have to verify that the server PHP settings in “php.ini” are set high enough to allow enough time for very long-running scripts/SQL statements to complete so that you end up with the import results screen (what high enough is, I could not say).

In addition to that, if a service such as CloudFlare is in place, those settings need to be set to longer than 3 minutes if possible - while the script will continue to run on the server, you won't be redirected to the import results screen if you get kicked out to an error screen. That said, you should be able to find the import error file using something like CPANEL to access the site file manager and for search for "sqlImport.errors". You may wish to open a support ticket with Siteground if you need any help with access.

If all else fails (e.g. like not being able to get your hands on a programmer fast enough to complete your import within a deadline), I have on more than one occasion resorted to breaking down a single import file to smaller ones (say 500 records in your case) to avoid the timing out altogether - incredibly frustrating, but at least my deadlines aren't missed!

Hope this helps! Tamar

  • Just to comment on "high enough"... we have php memory limit up to 2gb (ridiculous!) and import shows this behavior if I go over about 10k at a time. Haven't explored other config options too much as that is enough for our purposes here. – Eli Lisseck Dec 13 '16 at 21:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.