0

Joomla 3.5.1, Linux, Php 5.6.20

Is there a "quick fix" I could make to a script to allow it to either recognize the database, or would it be OK to manually change the database version number only back to 4.6.15?

When I try to upgrade from 4.6.16, to 4.7.7 it says that it doesn't recognize database version 4.6.16. It says:

Your database is marked with an unexpected version number: 4.6.16. The automated upgrade to version 4.6.7 can not be run - and the 4.6.7 codebase may not be compatible with your database state. You will need to determine the correct version corresponding to your current database state. You may want to revert to the codebase you were using prior to beginning this upgrade until you resolve this problem.

In addition, the actual error message is NOT formatted correctly. The full message (as it appears on screen) is:

An error has occurred.
 0 <div id="crm-container" class="crm-container" lang="en" xml:lang="en"> <style type="text/css" media="screen"> @import url(/main/administrator/components/com_civicrm/civicrm/css/civicrm.css); @import url(/main/administrator/components/com_civicrm/civicrm/bower_components/jquery-ui/themes/smoothness/jquery-ui.min.css); </style> <div class="messages status no-popup"> <div class="icon red-icon ui-icon-alert"></div> <span class="status-fatal">Sorry but we are not able to provide this at the moment.</span> <div class="crm-section crm-error-message">Your database is marked with an unexpected version number: 4.6.16. The automated upgrade to version 4.6.7 can not be run - and the 4.6.7 codebase may not be compatible with your database state. You will need to determine the correct version corresponding to your current database state. You may want to revert to the codebase you were using prior to beginning this upgrade until you resolve this problem.</div> <p><a href="http://ahymsin.org/main/administrator/" title="Main Menu">Return to home page.</a></p> </div> </div> <script language="JavaScript"> function toggle( element ) { var className = element.className; if ( className == 'crm-accordion-wrapper collapsed crm-fatal-error-details-block') { element.className = 'crm-accordion-wrapper crm-fatal-error-details-block'; } else { element.className = 'crm-accordion-wrapper collapsed crm-fatal-error-details-block'; } } </script>
  • 2
    Could you confirm which version you are trying to upgrade to, as your question mentions 3 versions: 4.7.4 in the title, 4.7.7 in the description and 4.6.7 in the error message. – davejenx May 5 '16 at 9:44
  • Sorry. Yes, to 4.7.7. Title corrected – tabletguy May 5 '16 at 14:57
2

Error found: I downloaded the correct 4.7.7 to my computer, but then uploaded 4.6.7 to the server by mistake and ran that installation. Thanks @davejenx for noticing this.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.