I am trying to import multiple participants from a CSV file into Civi as event participants. I am running into an issue when I go to match the required fields. I keep receiving an error because the Participant Status ID doesn't match.

This is a historic event I am trying to enter from another database, so I don't believe we have a match for this field. Is there a way to get around this?

Most of the constituents are already in Civi and have an external identifier from the past database. I now just to update their record to note that they attended the event.

  • do you have a column for participants status name(registered, attended, canceled etc), change it to the status id, civicrm/admin/participant_status?reset=1, if you don't have that column add it and indicate the status with the id
    – Kboy
    May 5, 2016 at 18:32
  • Thanks for your response. I tried that strategy and it still gave me the same error notification. Any other ideas?
    – Allison
    May 5, 2016 at 21:30
  • can you test with dummy data on the demo site? the participant status id should be something like 2 for attended or match your participant status
    – Kboy
    May 5, 2016 at 22:44

3 Answers 3


"Participant Status ID doesn't match" means the value(s) you are trying to insert into this field do not match the option values defined in CiviCRM.

Both Particpant status and Participant status Id are in the list of possible fields to import. Although the UI indicates that you need to import Participant status Id I think you can import participant status instead provide the text you import matches exactly with the defined options.

You could be tring to import values such as 'Registered' or 'Attended' into Participant status Id when it is expecting numerical values or you could be trying to import a text value into Participant status that is not one of the defined options. (perhaps 'Att' or 'attended' instead of 'Attended')

  • I like this answer - Allison: did you work it out? Jul 5, 2016 at 12:27

Is your CSV file actually comma-delimited?

If you choose another delimiter (e.g. semicolon or tab), the import might not work. Been stuck with this issue for hours before figuring out that might actually be a bug in CiviCRM.

See: Can't import Event participants


If the file you uploaded did not use commas as the file delimiter, then it's likely you were seeing CRM-19192: Event participants (and possibly other entity) imports do not handle "non-comma CSV".

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.