By default, all contributions add the associated email address to our mailing list. In the case of people who are either already subscribed, or who are logged in to a Drupal account (which also are default opted in to the mailing list), upon completing the contribution, they receive a CiviCRM info message stating " is already subscribed to the list."

Obviously we'd like to avoid this if possible. Is there a way to avoid trying to subscribe people to the list if they are already added?

1 Answer 1


Unfortunately, this is a consequence of using the profile to add contacts to a group. There are a couple of ways to work around this that may be better for your needs:

  • Make a smart group. If everyone who makes a contribution should be in a group, why record that information separately from the contribution? Just make the email list a smart group of all contacts with contributions.

  • Have people opt in. Are you certain that donors know they're signing up for the email list? If not, you really should make that explicit. You could add the "Group(s)" field to the profile to let people choose among all public groups, or you could add a single checkbox field for someone to say they'd like to subscribe, and you could base a smart group on that.

  • CiviRules. You may find that you can create a workflow for this step using CiviRules and if it does throw up a warning about the contact already being in the group, at least it is out of public view

  • I had previously used the opt-in method, but I was overruled. The list syncs with MailChimp, so unfortunately smart groups don't quite work for us. May 6, 2016 at 21:27
  • 1
    In that case, you're out of luck--sorry. You might be able to configure CiviRules to do this, I suppose, but there's nothing within core CiviCRM.
    – Andie Hunt
    May 6, 2016 at 21:29
  • AH - thought that was a good option so added to your answer - hope that is okay. i know SE 'likes' lots of answers, but i think for users it is better to give one substantial one that covers all the options ;-)
    – petednz - fuzion
    May 6, 2016 at 23:16
  • @petednz no problem--thanks!
    – Andie Hunt
    May 7, 2016 at 0:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.