4

CiviCRM no longer officially supports Drupal 6.x. as of version 4.2 but seems that more than one is running versions above 4.1 with Drupal 6 site.

Up to what CiviCRM version I can upgrade my Drupal 6 site without suffering any incompatibility?

6

Pete is right that even recent versions of CiviCRM (certainly in the 4.6.x series) work with Drupal 6 sites. The "no longer officially supports" issue is that the core team won't go out of their way to make D6-specific fixes.

That said, I have encountered problems with new installations on Drupal 6, but this has been for testing--why else would someone build a new site on Drupal 6?

5

We have Drupal 6 sites running just fine on the 4.6.x series. I don't know where you read that 'civicrm no longer supports drupal 6" - is it not more the case that Drupal no longer supports Drupal 6 and hence all module information concerning D6 is incorrect

2
  • 3
    In this wiki page Installing CiviCRM for Drupal 6 there is a red warning that says: IMPORTANT: As of version 4.3, CiviCRM no longer officially supports Drupal 6.x. Some community members have tested it and report it to be working, but nothing is guaranteed. – Francesc Bassas i Bullich May 10 '16 at 10:11
  • 1
    Thank you. had no idea that comment was out there. never had an issue with doing the upgrades, but are in the final round of getting last clients off D6. – petednz - fuzion May 10 '16 at 18:39
3

I have been running Civi 4.7.6 on a Drupal 6.38 production site. Seems to be working just fine :-) Am busy installing to security upgrade 4.7.7 now so hold thumbs nothing breaks :-)

3
  • 1
    I've been very wary of going past 4.5.x on a couple of D6 sites that I look after, primarily driven by PHP version compatibility concerns. The wiki states that PHP 5.5 is recommended for 4.6 and 5.7, whilst drupal.org states "PHP 5.3.x and higher may produce errors or unexpected behavior especially for contributed modules and themes" with D6. I'm running 5.3.3 on a Debian box. – Graham May 11 '16 at 8:53
  • 1
    I blindly upgraded without thinking it through, but fortunately have had no problems. I'm using PHP 5.4.21 and receive errors if I try upgrade to 5.5. I'm on a linux server. – Davy Ivins May 11 '16 at 19:55
  • 2
    contd... I haven't picked up any problems after upgrading to Civi 4.7.7 last night. I have a PILE of Drupal modules and have installed a few extensions (CiviDiscount, Cividesk Sparkpost, publicautocomplete, and noverwrite.) – Davy Ivins May 11 '16 at 20:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.