0

Since upgrade, I am not able to renew membership from backend. As soon I press RENEW I am getting this Fatal Error message:

2016/05/13 11:57:55 [error] 8711#0: *2228 FastCGI sent in stderr: "PHP message: PHP Fatal error: Cannot pass parameter 2 by reference in /www/demo/sites/all/modules/civicrm/api/v3/utils.php on line 1408" while reading response header from upstream, client: 185.59.126.181, server: demo.com, request: "POST /civicrm/contact/view/membership HTTP/2.0", upstream: "fastcgi://unix:/var/run/php-fpm/demo.com.sock:", host: "demo.com", referrer: "https://demo.com/civicrm/contact/view/membership?action=renew&reset=1&cid=398&id=52&context=membership&selectedChild=member"

Can anyone help please? how to fix this?

  • Are you on PHP 5.6? – KarinG - Semper IT May 13 '16 at 12:16
  • I am using PHP 5.5 – Tapash May 13 '16 at 12:17
  • Did you upgrade from 4.6.15 -> 4.6.16? – KarinG - Semper IT May 13 '16 at 12:20
  • No, I have upgraded from 4.6.14 – Tapash May 13 '16 at 12:21
  • Ok - good. I will have a look - this AM - and get back to you – KarinG - Semper IT May 13 '16 at 12:29
1

@Tapash - I just tried to reproduce this on one of our live 4.6.16 projects and I can not.

From a Contact's Membership I'm successfully able to both:

  • more -> Renew [no errors; renewed properly] &
  • more -> Renew-Credit Card [no errors; made payment; got receipt; renewed properly]

I've also checked the JIRA issues and I don't see anyone else describing what you're observing. Considering your other Q as well - I'm wondering if perhaps something went wrong during your recent upgrade?

General recipe for this is to restore both code base (files) & databases back to 4.6.14 and then to run the upgrade script [to 4.6.16] again. If you can: run it via drush - it may give you some warnings/errors that give you some insight as to what's going on.

sudo -u apache drush civicrm-upgrade-db

| improve this answer | |
1

Looks like a conflicting extension was causing the problem. CiviRules. Once that is uninstalled everything seems to be working perfectly fine.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.