1

Using Joomla! 3.5.1/CiviCRM 4.7.7./Debug Enabled. Accessing online contribution page reports permissions error. Both Apache and Civicrm logs reports fatal permissions error. Civicrm/Joomla ACL backend administration page will NOT update change to allow public view of contribution page. Followed various suggestions in forum and here which points to prefix_asset table with no change.

While going thru apache logs also noticed 404 error messages generated from GETs similar to /components/com_civicrm/civicrm/bower_components. Problems with these GETs: bower_components is in /administrator/component/com_civicrm/cvicrm NOT /components/com_civicrm/civicrm. Need to know where to change settings to direct calls to administrator.

Snippet from log

May 13 14:20:58  [info] $backTrace = #0 /var/www/html/hydra/administrator/components/com_civicrm/civicrm/CRM/Core/Error.php(371): CRM_Core_Error::backtrace("backTrace", TRUE)
#1 /var/www/html/hydra/administrator/components/com_civicrm/civicrm/CRM/Utils/System/Joomla.php(464): CRM_Core_Error::fatal("You do not have permission to access this page.")
#2 [internal function](): CRM_Utils_System_Joomla->permissionDenied()
#3 /var/www/html/hydra/administrator/components/com_civicrm/civicrm/CRM/Utils/System.php(74): call_user_func_array((Array:2), (Array:0))
#4 /var/www/html/hydra/administrator/components/com_civicrm/civicrm/CRM/Core/Invoke.php(232): CRM_Utils_System::__callStatic("permissionDenied", (Array:0))
#5 /var/www/html/hydra/administrator/components/com_civicrm/civicrm/CRM/Core/Invoke.php(232): CRM_Utils_System::permissionDenied()
#6 /var/www/html/hydra/administrator/components/com_civicrm/civicrm/CRM/Core/Invoke.php(86): CRM_Core_Invoke::runItem((Array:15))
#7 /var/www/html/hydra/administrator/components/com_civicrm/civicrm/CRM/Core/Invoke.php(54): CRM_Core_Invoke::_invoke((Array:3))
#8 /var/www/html/hydra/components/com_civicrm/civicrm.php(90): CRM_Core_Invoke::invoke((Array:3))
#9 /var/www/html/hydra/components/com_civicrm/civicrm.php(11): civicrm_invoke()
#10 /var/www/html/hydra/libraries/cms/component/helper.php(405): require_once("/var/www/html/hydra/components/com_civicrm/civicrm.php")
#11 /var/www/html/hydra/libraries/cms/component/helper.php(380): JComponentHelper::executeComponent("/var/www/html/hydra/components/com_civicrm/civicrm.php")
#12 /var/www/html/hydra/libraries/cms/application/site.php(191): JComponentHelper::renderComponent("com_civicrm")
#13 /var/www/html/hydra/libraries/cms/application/site.php(230): JApplicationSite->dispatch()
#14 /var/www/html/hydra/libraries/cms/application/cms.php(257): JApplicationSite->doExecute()
#15 /var/www/html/hydra/index.php(49): JApplicationCms->execute()
#16 {main}
  • Novice interim solution> Resolve HTTP 404 errors: (1) Changed directory (cd) <Joomla Root>/component/com_civicrm/; and (2) ln -s ../../administrator/components/com_civicrm/civicrm civicrm; This step accelerated my ability to troubleshoot Contribution page error. Front page error messages were visible and reveal misconfiguration error. – Flash L May 14 '16 at 18:06

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.