1

After succesfull updating civicrm 4.6.15 to 4.6.16 (files are installed database is updated), I find that access to contactdata in the admin side of my joomla 3.5.1 website has gone. I get a white screen, and after going back to the previous page I get an error notive that says: "Invalid Entity Filter"

I flushed the cache but that does not change anything. At the frontend of the website I can change my contactdata and save them and get the usual okay message after that. I cannot open the samen contactdata in the backend. I recreated the site from a backup updated again and got the same results again.

I updated another joomla 3.5.1 site with the same civi version 4.6.15 and that went without any problems.

I set error reporting to maximum in Joomla and do not get any errormessages at all only an empty white screen.

As advised in the comment below I checked the error log inside civicrm.

I got this error-message in a sea of messages:

"$Fatal Error Details = array(3) {
  ["message"]=>
  string(21) "Invalid Entity Filter"
  ["code"]=>
  NULL
  ["exception"]=>
  object(CRM_Core_Exception)#448 (10) {
    ["errorData":"CRM_Core_Exception":private]=>
    array(1) {
      ["error_code"]=>
      int(0)
    }
    ["cause":protected]=>
    NULL
    ["_trace":"PEAR_Exception":private]=>
    NULL
    ["message":protected]=>
    string(21) "Invalid Entity Filter"
    ["string":"Exception":private]=>
    string(0) ""
    ["code":protected]=>
    int(0)
    ["file":protected]=>
    string(105) "/home/--deleted--/civi/administrator/components/com_civicrm/civicrm/CRM/Core/BAO/CustomGroup.php"
    ["line":protected]=>
    int(658)
    ["trace":"Exception":private]=>
    array(14) {
      [0]=>
      array(6) {
        ["file"]=>
        string(105) "/home/--deleted--/civi/administrator/components/com_civicrm/civicrm/CRM/Core/BAO/CustomGroup.php"
        ["line"]=>
        int(449)
        ["function"]=>
        string(23) "validateSubTypeByEntity"
        ["class"]=>
        string(24) "CRM_Core_BAO_CustomGroup"
        ["type"]=>
        string(2) "::"
        ["args"]=>
        array(2) {
          [0]=>
          string(10) "Individual"
          [1]=>
          string(14) "Verenigingslid"
        }"

So: the code trows an exception. However I do not know why. I am logged in in the backend of joomla as superuser, so I should getaccess to all groups in civicrm, with no private execeptions???

  • 1
    I would start checking error logs in this order, CiviCRM, PHP, Apache/NginX and report back, let me know if you don't know how to access these error logs and I'll give instructions. – Andrei May 16 '16 at 23:01
2

I looks like CRM-18567 and CRM-18504

Have a look at Chris Burgess comment, there are couple of commits that seem to fix the issue.

https://github.com/fuzionnz/civicrm-core/commit/a0bcc16171d2f30c4416aeec079bab56c313390a https://github.com/fuzionnz/civicrm-core/commit/d3e9ab21a0f2256197125854fe6312c3fa0c8c8a

I would recommend to create a backup or replicate your installation in a development environment, apply the commits mentioned and check if it solves the issue.

  • Thanks: it is nice to know the problem is probably getting solved already. I looked at the two github pages with the changed files. What is the best way to copy the changed files, or: is there a way to avoid copy-pasting every change manually? – Paul Kleingeld May 18 '16 at 10:17
  • Okay: made a local installation, and manually edited customGroup.php using the code found in github.com/fuzionnz/civicrm-core/commit/…, and all seems well again! – Paul Kleingeld May 19 '16 at 14:16
  • If you are familiar with git, here's how you apply a patch via git so you don't have to manually edit the files: civicrm.stackexchange.com/a/4626/872 Also feel free to accept the answer so we keep Stackexchange happy – Andrei May 19 '16 at 14:42
  • Thanks Andrei for leading me to the solution of this issue. I am not at this moment enough of a commandline pro to apply the patch in one go, alas. But I got there in the end: copying and pasting solved the issue for me. – Paul Kleingeld May 20 '16 at 12:27
  • Civi version 4.6.17 works correct, so the problem got solved. – Paul Kleingeld Jun 6 '16 at 20:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.