0

I'm trying to get civi to run on Ubuntu xenial and drupal7. I installed the php5 repositories as per: https://askubuntu.com/questions/761713/how-can-i-downgrade-from-php-7-to-php-5-6-on-ubuntu-16-04

I successfully upgraded my database to 4.7.7 but then I get stuck on a screen that shows the following:

localhost Error The website encountered an unexpected error. Please try again later. Error message CiviCRM_API3_Exception: DB Error: no such field in civicrm_api3() (line 45 of /usr/share/drupal7/modules/civicrm/api/api.php).

Not sure if it has something to do with the access_compat errors I was getting while installing, things like this in my apache 2 error.log [Tue May 17 14:22:54.236734 2016] [access_compat:error] [pid 32145] [client 127.0.0.1:35040] AH01797: client denied by server configuration: /usr/share/drupal7/sites/default/files/civicrm/ConfigAndLog/CiviCRM.63a720ea8e0f63f2f91fb59f72af16dc.log

Any leads appreciated!

  • I should add xenial uses mysql 5.7 – Matt Allard May 17 '16 at 19:47
2

I think I may have gotten it. I upgraded to Ubuntu Xenial holding back with apt-mark all packages that matched drupal7, php, mysql and apache. Booted into my new system and all seems ok for now so I have my up to date desktop and a working civicrm setup. Thanks for listening.

  • good to hear you got things sorted. we were 'listening' ;-) – petednz - fuzion May 18 '16 at 2:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.