0

With CiviCRM 4.7.7 on Drupal 6, we are seeing crashes such as:

    May 18 11:16:34  [info] $Fatal Error Details = Array
(
    [message] => One of parameters  (value: `1-street_address`) is not of the type MysqlColumnName
    [code] =>
)


May 18 11:16:34  [info] $backTrace = #0 /srv/www/sites/orgdomainname.org/www/sites/all/modules/civicrm/CRM/Core/Error.php(371): CRM_Core_Error::backtrace("backTrace", TRUE)
#1 /srv/www/sites/orgdomainname.org/www/sites/all/modules/civicrm/CRM/Utils/Type.php(424): CRM_Core_Error::fatal("One of parameters  (value: `1-street_address`) is not of the type MysqlColumn...")
#2 /srv/www/sites/orgdomainname.org/www/sites/all/modules/civicrm/CRM/Utils/Sort.php(124): CRM_Utils_Type::validate("`1-street_address`", "MysqlColumnName")
#3 /srv/www/sites/orgdomainname.org/www/sites/all/modules/civicrm/CRM/Core/Selector/Controller.php(222): CRM_Utils_Sort->__construct((Array:7), NULL)
#4 /srv/www/sites/orgdomainname.org/www/sites/all/modules/civicrm/CRM/Profile/Page/Listings.php(394): CRM_Core_Selector_Controller->__construct(Object(CRM_Profile_Selector_Listings), NULL, NULL, 4, Object(CRM_Profile$
#5 /srv/www/sites/orgdomainname.org/www/sites/all/modules/civicrm/CRM/Profile/Page/Router.php(124): CRM_Profile_Page_Listings->run()
#6 /srv/www/sites/orgdomainname.org/www/sites/all/modules/civicrm/CRM/Core/Invoke.php(312): CRM_Profile_Page_Router->run((Array:2), NULL)
#7 /srv/www/sites/orgdomainname.org/www/sites/all/modules/civicrm/CRM/Core/Invoke.php(86): CRM_Core_Invoke::runItem((Array:13))
#8 /srv/www/sites/orgdomainname.org/www/sites/all/modules/civicrm/CRM/Core/Invoke.php(54): CRM_Core_Invoke::_invoke((Array:2))
#9 /srv/www/sites/orgdomainname.org/www/sites/all/modules/civicrm/drupal/civicrm.module(345): CRM_Core_Invoke::invoke((Array:2))
#10 [internal function](): civicrm_invoke("profile")
#11 /srv/www/sites/orgdomainname.org/www/includes/menu.inc(350): call_user_func_array("civicrm_invoke", (Array:1))
#12 /srv/www/sites/orgdomainname.org/www/index.php(17): menu_execute_active_handler()
#13 {main}

This looks similar to what is reported here:

CRM-18510 "Getting 'One of parameters (value: Home-street_address) is not of the type MysqlColumnName' error when Contact Search is used."

However since we are seeing the error when trying to submit forms (CiviMember + CiviContribute + Profile) rather than to search, I am not sure if what is reported with CRM-18510 is actually the same as what we are seeing.

If it is probably the same, please point me to what diff/patch I should test applying to our CiviCRM 4.7.7 on D6 configuration.

I am thankful,

Michael

1

This looks likely to be the same underlying problem as the issue described in CRM-18510. There's a fix referenced there: https://github.com/civicrm/civicrm-core/pull/8317 . If you test this out, do report your findings here and on CRM-18510 . Hope it works for you.

Regards,

Dave

  • Is there some way to download from github as a patch file that may be applied with patch? I found a YouTube video showing such, however the example was showing how to convert a single commit to a patch by simply adding ".patch" to the URL. This CRM-18510 there are five commits for. What is on the "Files Changed" tab looks complete, however it will not apply as a patch. – Michael Lueck May 20 '16 at 11:54
  • Try patch-diff.githubusercontent.com/raw/civicrm/civicrm-core/pull/… This includes changes to unit tests under the civicrm/tests/ directory, which only exists in development installations, so you may want to remove those parts from the patch before applying. – davejenx May 20 '16 at 12:40
  • Thank you very much Dave. I just applied that Diff to our test site and ran a test new member join. I got back from CiviCRM: Your transaction has been processed successfully. Please print this page for your records. An email receipt has also been sent to test2@orgdomainname.org With that success I applied the patch to Prod as well. Now the wait to see who fills out a CiviCRM form next, and if it too successfully processes. "The suspense is terrible, I hope it will last." Willy Wonka ;-) – Michael Lueck May 21 '16 at 18:25
  • I just received confirmation that transactions now successfully are processing in Prod. I will try to update the CRM-18510 case explaining your patch URL works in our site's case. Thank you so much! :-) – Michael Lueck May 24 '16 at 20:45
  • Glad to have helped. Well done for updating the JIRA issue. Thanks for accepting the answer. If you feel it's useful, it's usual to up-vote too - a quirk of Stack Exchange, see Accepting answer without upvoting? – davejenx Jun 14 '16 at 14:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.