3

I'm getting a Geocoding over-limit error, even though I've enabled a billing profile with my Google Maps Geocoding API key. (I hope! :) )

Using: Civi 4.6.14, Drupal 7.43, Geocoding settings: Mapping provided by Google, with my Google Maps Geocoding API key Geocoding provided by Google, with the same Google Geocoding API key, on a standard account. I have setup a billing profile with the key, so it should handle over-usage. Scheduled job: geocoding=1, address parsing=1, throttle=1.

The Scheduled job returns this error:

Parameters parsed (and passed to API method): a:4: {s:7:"version";i:3;s:9:"geocoding";s:1:"1";s:5:"parse";s:1:"1";s:8:"throttle";s:1:"1";}

Full message: Finished execution of Geocode and Parse Addresses with result: Failure, Error message: A fatal error was triggered: Aborting batch geocoding. Hit the over query limit on geocoder.

Also, my Google developer's console shows no activity on my API key.

So, I'm wondering if I have missed something in Civicrm... for instance I found this link: https://wiki.civicrm.org/confluence/display/CRMDOC/Mapping+and+Geocoding It says at the bottom:

Usage Limits Some providers have usage limits on their Mapping and Geocoding APIs. If you go over the limits you may receive a overlimit error when trying to save an address. Currently there is no support for integrating the Google APIs Console license (which is needed for sites whose usage is over limit). Contact info at civicrm dot org if you are interested in helping implement this.

Does this mean that Civi can't handle over-billing?

OR: perhaps I have not configured my Google API key properly. I think I've set it to only accept connections from our server's IP, and with our domains.

Any ideas?

I've subsequently followed the advice here to switch mapping to Open Street Maps and Geocoding to Yahoo, and re-activated the Scheduled Job. That is currently running with no errors... :)

  • You may also be interested in: issues.civicrm.org/jira/browse/CRM-18150 – John May 20 '16 at 7:52
  • Whew! That's a cat amongst the pigeons... I guess this is something the core team will need to examine. – Andyg8 May 20 '16 at 10:11
  • However, it would be moderately disastrous for us to lose the proximity search functionality! – Andyg8 May 20 '16 at 10:29
  • There may be other geocoding providers with less strict terms of use, but we need to be certain ;] – John May 20 '16 at 10:45
  • A possible solution to the proximity search issue... perhaps it would be possible to separate functions. Eg geocode and parse addresses for storage using non-google providers - eg Yahoo. And then do proximity lookups using Google? – Andyg8 May 21 '16 at 1:27
2

You weren't imagining things. CiviCRM 4.6 and 4.7 until recently was ignoring the Google API key altogether! I'm not sure the history of that, but it would have been great if someone had documented that in the settings. As of the latest 4.6 and 4.7 the Google API key is getting recognized again (https://github.com/civicrm/civicrm-core/blob/4.6.23/CRM/Utils/Geocode/Google.php). Once I upgraded, I checked the URL getting passed and it now attaches the key and uses https (the other requirement of Google). And in the API dashboard I'm now seeing activity.

So the answer to your question is: upgrade CiviCRM to the latest in order to get Geocoding to use your Google API key.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.