6

I created a custom data set called Volunteer Fields with one field. The name of the field is "Volunteer?". It's a Yes/No radio button and it's marked as Searchable. The documentation says:

Is this Field Searchable? Makes the field appear in a panel of custom fields in CiviCRM's Advanced Search page.

I can't see it in Advanced Search. I can see and edit the field on the View Contact screen. I can search on the Volunteer? field using Search Builder, but there's no panel for custom fields in Advanced Search. I can't find the field anywhere in Advanced Search. Please Help...thanks!!

  • There seems to be an issue with the Advanced Search section. Sometimes custom fields don't show up and sometimes they do. The Search Builder works even when custom fields don't appear in Advanced Search though. – moopet Jun 16 '16 at 16:04
5

Navigate to Administer - Customize data and screens - Display preferences and select the Custom field section listed under Contact search. After that you should see the Custom field accordion in the Advanced search

  • That's checked by default - right? But good point - perhaps that box got unchecked. – KarinG - Semper IT May 21 '16 at 21:11
  • Sometimes when I deploy a test Civi instance I usually have to check the option, I thought it might be a good addition. – Andrei May 21 '16 at 22:31
  • Agree! I vote you up. – KarinG - Semper IT May 21 '16 at 22:34
  • 1
    No, not checked by default. I looked there but didn't see it the first time. Thanks so much!!! – jimcrist May 21 '16 at 23:41
  • It's checked by default when I install CiviCRM. – moopet Jun 16 '16 at 15:59
4

Ah - yes - it's easily overlooked: In Search -> Advanced Search -> click the Custom Fields fieldset to see your Custom data sets. I just created a Custom data set: Date SE with a MyDate field in it for another SE question -> I made it searchable - and here it is [and this is 4.7.7]:

enter image description here

0

In response to Moopet's comment above.

I had an issue today where a Custom Data field set I'd created previously (activity Data) was not showing in advanced search, neither did it show in Find Activities, but it was avilable for reports and in Search Builder. (All fields in the set were marked as searchable).

I realised that the fields were linked to some activity types that had been disabled recently.

I re-enabled the activity types, then in the Data Set settings dis-associated the Data set from the activity types, and then disabled the activity types again.

The Field set now shows in Advanced Search as expected.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.