1

I am working on an issue regarding Date Formats (Localization > Date Formats) and it took me a while to realize it is caching due to which changes in Localization.settings.php file were not being reflected. Even after the realization, after every small change I have to clear the cache manually. I used drush ($ drush cc civicrm) to do it which takes about a minute everytime and it is hectic.

So, how can I disable caching?

1

Caching methods can be enabled or disabled in your CiviCRM settings file (eg: civicrm.settings.php).

The setting you're looking for is: CIVICRM_DB_CACHE_CLASS

To disable caching, change the value to 'NoCache'. Other possible settings are documented above the setting in the file.

There is a page about caching in the documentation here: https://wiki.civicrm.org/confluence/display/CRMDOC/Cache+Reference

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.