0

I am running CiviCRM 4.7.6 on Drupal 7.43 on a CentOS 7 platform. I need to install CiviSMS with the Twilio and am running into a problem with the PHP version requirement of 5.5. CentOS natively has PHP 5.4.16. Can anyone advise on a better platform that gives me the ability to run CiviSMS?

3
  • This question is really not about Civi at all. Try a Linux forum.
    – Coleman
    May 25, 2016 at 15:07
  • Which is requiring PHP 5.5, CiviSMS or Twilio? We run CiviSMS with Twilio on PHP 5.4... Jun 23, 2016 at 5:34
  • I have PHP and MySQL at the proper versions now on CentOS 7. Working on the install of Twilio, but directions on civiCRM suggest Twilio is not an option. I have civiCRM 4.7.9 on Drupal.
    – bob bowen
    Jul 14, 2016 at 15:52

2 Answers 2

1

Depending upon your hosting, you might be able to upgrade PHP on your CentOS server. A quick Google search showed some options, but I can't vouch for any particular guide.

I tend to work more on the Ubuntu/Debian side of things, and Ubuntu 14.04 LTS ships with PHP 5.5.9 out of the box. (And Ubuntu 16.04 gives you the option of PHP 5.6 or PHP 7.0, which isn't yet supported by CiviCRM.) If you aren't set in your ways, you might try switching over.

1
  • I'm investigating Ubuntu 16.04 now but less familiar with sysadmin on that platform. So I was curious if anyone had a solid solution on CentOS or other similar platform.
    – bob bowen
    May 24, 2016 at 15:50
1

I don't think whatever PHP requirement you have is coming from CiviCRM or the Twilio extension. CiviCRM definitely doesn't require PHP 5.5 - and the Twilio code hasn't really changed for years, so I can't imagine that requires it either.

Please post a screenshot of the screen that says you need PHP 5.5 and maybe folks can help you more.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.